aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-19 12:19:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-19 12:19:28 +0000
commita69a79c0bc96c7ce1d4195ecb15d26205e52fac3 (patch)
tree72728088714d751e42166a4693a594e8941a9740 /Makefile
parent76014f37f44a222b084266b32d78cf13500b8648 (diff)
downloadmaster-187ad058-a69a79c0bc96c7ce1d4195ecb15d26205e52fac3.tar.gz
master-187ad058-a69a79c0bc96c7ce1d4195ecb15d26205e52fac3.tar.bz2
master-187ad058-a69a79c0bc96c7ce1d4195ecb15d26205e52fac3.zip
[buildroot] abort built in prereq target if there is no site config file for the current target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29798 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4d5d7885e0..44b4e944eb 100644
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,12 @@ endif
# check prerequisites before starting to build
prereq: $(target/stamp-prereq) tmp/.prereq_packages
+ @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
+ echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+ echo ' The missing file will cause configure scripts to fail during compilation.'; \
+ echo ' Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+ exit 1; \
+ fi
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE