aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-04 03:04:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-04 03:04:37 +0000
commit81e1c1bc169c278c4279df366c680fa619d8f8ab (patch)
tree1a06e20319c607374ff9474c8deacab844cf38e8 /Makefile
parent7d175ee6fb0ef8e833d0abc881c484a28c9aebc6 (diff)
downloadmaster-187ad058-81e1c1bc169c278c4279df366c680fa619d8f8ab.tar.gz
master-187ad058-81e1c1bc169c278c4279df366c680fa619d8f8ab.tar.bz2
master-187ad058-81e1c1bc169c278c4279df366c680fa619d8f8ab.zip
fix make clean for unconfigured build trees
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9655 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e56535eac4..970b0896ca 100644
--- a/Makefile
+++ b/Makefile
@@ -45,10 +45,10 @@ $(BUILD_DIR)/.prepared: Makefile
clean: FORCE
rm -rf $(BUILD_DIR) $(BIN_DIR)
$(MAKE) target/linux/clean
- rm -rf $(TMP_DIR)
dirclean: clean
rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+ rm -rf $(TMP_DIR)
# check prerequisites before starting to build
prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;