aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-21 02:00:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-21 02:00:11 +0000
commit75d1732f135087777e2572fe136d5bb271f757f4 (patch)
tree1e7917003e487425e3facbe83142649d3b824655 /Makefile
parent20a0a230216e621021f8e08caceafe93f1c7ad9d (diff)
downloadmaster-187ad058-75d1732f135087777e2572fe136d5bb271f757f4.tar.gz
master-187ad058-75d1732f135087777e2572fe136d5bb271f757f4.tar.bz2
master-187ad058-75d1732f135087777e2572fe136d5bb271f757f4.zip
Makefile: add a check to bail out early when the path to the openwrt directory contains spaces (#12344)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33884 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 348e645005..5257a990dc 100644
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,10 @@ LC_ALL:=C
LANG:=C
export TOPDIR LC_ALL LANG
+empty:=
+space:= $(empty) $(empty)
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+
world:
include $(TOPDIR)/include/host.mk