aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:47:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:47:16 +0000
commit6c9b1a278e484a9c7c5ff36f91da90f725776d00 (patch)
tree7bcdd159e62e694c52cf86796af7d0679e607a2b /Makefile
parent078f9f266ab26e9fb0fbebabb0bd8c5dfa3e834c (diff)
downloadmaster-187ad058-6c9b1a278e484a9c7c5ff36f91da90f725776d00.tar.gz
master-187ad058-6c9b1a278e484a9c7c5ff36f91da90f725776d00.tar.bz2
master-187ad058-6c9b1a278e484a9c7c5ff36f91da90f725776d00.zip
Makefile: move the cleaning of staging_dir/target* from dirclean to clean
Currently "make clean" only clears the build_dir/target*, but leaves staging_dir/target* intact. "make clean" should also clean the staging_dir/target* directories, as in the current situation some old packages or libraries may be linked into the firmware from staging_dir despite a "make clean". The patch reorganises clean / dirclean functionality so that * "make clean" also clears the staging_dir/target* in addition to build_dir/target*. * "make dirclean" clears toolchain and host(=tools) directories from both build_dir and staging_dir signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45973 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f89527f81c..a12e3ea49a 100644
--- a/Makefile
+++ b/Makefile
@@ -50,10 +50,10 @@ printdb:
prepare: $(target/stamp-compile)
clean: FORCE
- rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
+ rm -rf $(BUILD_DIR) $(STAGING_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
dirclean: clean
- rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
+ rm -rf $(STAGING_DIR_HOST) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
rm -rf $(TMP_DIR)
ifndef DUMP_TARGET_DB