aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-28 13:38:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-28 13:38:34 +0000
commit52ea8edba3bdb980ce7850eab1af90647e6cb7fc (patch)
tree5db5fc51e7d6c860860576941ccba0c6bb768c10 /Makefile
parentf01fd8e50b189be59e546e9a9dcb2db71e98682f (diff)
downloadmaster-187ad058-52ea8edba3bdb980ce7850eab1af90647e6cb7fc.tar.gz
master-187ad058-52ea8edba3bdb980ce7850eab1af90647e6cb7fc.tar.bz2
master-187ad058-52ea8edba3bdb980ce7850eab1af90647e6cb7fc.zip
build: clean up sitefiles, make them per-arch
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45090 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 91b6946ac3..2b08d30ffe 100644
--- a/Makefile
+++ b/Makefile
@@ -75,10 +75,10 @@ endif
# check prerequisites before starting to build
prereq: $(target/stamp-prereq) tmp/.prereq_packages
- @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
- echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+ @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
+ echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
echo ' The missing file will cause configure scripts to fail during compilation.'; \
- echo ' Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+ echo ' Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
exit 1; \
fi