aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2007-04-07 11:53:18 +0000
committerMike Baker <mbm@openwrt.org>2007-04-07 11:53:18 +0000
commit2b625644e2cf302647c56c2419db56be654e77db (patch)
tree893f56da610edc0710adb9157687f60003df3d19 /Makefile
parent4975d737e7cfe689978fdb2f41a7f2da2a1b7150 (diff)
downloadmaster-187ad058-2b625644e2cf302647c56c2419db56be654e77db.tar.gz
master-187ad058-2b625644e2cf302647c56c2419db56be654e77db.tar.bz2
master-187ad058-2b625644e2cf302647c56c2419db56be654e77db.zip
same as [6881]
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6882 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index d7e4585595..cab2486fb1 100644
--- a/Makefile
+++ b/Makefile
@@ -62,10 +62,10 @@ tmp/.config-%.in: tmp/.%info
.config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
- @[ -f .config ] || { \
- [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+ @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+ cp $(HOME)/.openwrt/defconfig .config; \
$(NO_TRACE_MAKE) menuconfig; \
- }
+ fi
@$< -D .config Config.in &> /dev/null
scripts/config/mconf: