aboutsummaryrefslogtreecommitdiffstats
path: root/Config.in
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:35 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:35 +0000
commit405fb366b1bca253f97de49ada16a76913588e88 (patch)
tree880ccaed7ef125b6f5f0d9dd11d6a6b734d9f7fe /Config.in
parent704e2ed39d4e157d0c24d4dc3a3078cbacc6505c (diff)
downloadmaster-187ad058-405fb366b1bca253f97de49ada16a76913588e88.tar.gz
master-187ad058-405fb366b1bca253f97de49ada16a76913588e88.tar.bz2
master-187ad058-405fb366b1bca253f97de49ada16a76913588e88.zip
include/image.mk: do not make initramfs build exclusive
Allow building initramfs along with other types of filesystems. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37050 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Config.in')
-rw-r--r--Config.in8
1 files changed, 2 insertions, 6 deletions
diff --git a/Config.in b/Config.in
index 8dd73cc258..98e3e046f9 100644
--- a/Config.in
+++ b/Config.in
@@ -78,7 +78,6 @@ menu "Target Images"
config TARGET_ROOTFS_EXT4FS
bool "ext4"
default y if USES_EXT4
- depends on !TARGET_ROOTFS_INITRAMFS
help
Ext4 file system with some free space for uml images
@@ -86,35 +85,32 @@ menu "Target Images"
bool "iso"
default n
depends on TARGET_x86_generic
- depends on !TARGET_ROOTFS_INITRAMFS
help
Create some bootable ISO image
config TARGET_ROOTFS_JFFS2
bool "jffs2"
default y if USES_JFFS2
- depends on !TARGET_ROOTFS_INITRAMFS
help
Build a jffs2 root filesystem
config TARGET_ROOTFS_JFFS2_NAND
bool "jffs2 for NAND"
default y if USES_JFFS2_NAND
- depends on !TARGET_ROOTFS_INITRAMFS && USES_JFFS2_NAND
+ depends on USES_JFFS2_NAND
help
Build a jffs2 root filesystem for NAND flash
config TARGET_ROOTFS_SQUASHFS
bool "squashfs"
default y if USES_SQUASHFS
- depends on !TARGET_ROOTFS_INITRAMFS
help
Build a squashfs-lzma root filesystem
config TARGET_ROOTFS_UBIFS
bool "ubifs"
default y if USES_UBIFS
- depends on !TARGET_ROOTFS_INITRAMFS && USES_UBIFS
+ depends on USES_UBIFS
help
Build a ubifs root filesystem