aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-07 09:36:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-07 09:36:55 +0000
commitfe76629390428a6485001d870119782559b44687 (patch)
tree25337293f83f5b8bbc65c5e416bd514a4c3aeb04
parent46123400c865b202121ae057be6611b3748d3afc (diff)
downloadmaster-187ad058-fe76629390428a6485001d870119782559b44687.tar.gz
master-187ad058-fe76629390428a6485001d870119782559b44687.tar.bz2
master-187ad058-fe76629390428a6485001d870119782559b44687.zip
[package] libiptc and libxtables should install their libraries as symbolic links (#5313, #5639)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17162 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/iptables/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 190b69477d..818e686d47 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=08cd9196881657ea0615d926334cb7e9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -329,12 +329,12 @@ endef
define Package/libiptc/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
endef
define Package/libxtables/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so* $(1)/usr/lib/
endef
define BuildPlugin