aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-23 12:32:36 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-23 12:32:36 +0000
commitebf03a147db6204a6c109a4601f113413058515c (patch)
tree40291de09bdb4b9d3b7eac24dafdd1203d65b6dd
parent4cc8018f7166be5ad1f90e2c79b7d4cfe1b88d93 (diff)
downloadmaster-187ad058-ebf03a147db6204a6c109a4601f113413058515c.tar.gz
master-187ad058-ebf03a147db6204a6c109a4601f113413058515c.tar.bz2
master-187ad058-ebf03a147db6204a6c109a4601f113413058515c.zip
modules: add 6LoWPAN over Bluetooth Low Energy
Adding support 6LoWPAN over Bluetooth Low Energy in kernel 3.18. Creating new bluetooth_6lowpan group with CONFIG_6LOWPAN and CONFIG_BT_6LOWPAN. Adding kernel object dependencies for 6LoWPAN over Bluetooth Low Energy. Signed-off-by: Lukasz Duda <lukasz.duda@nordicsemi.no> Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44084 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/linux/modules/other.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index eed258dc22..70acf54727 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -70,6 +70,26 @@ endef
$(eval $(call KernelPackage,bluetooth))
+define KernelPackage/bluetooth_6lowpan
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Bluetooth 6LoWPAN support
+ DEPENDS:=+kmod-bluetooth @!(LINUX_3_3||LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
+ KCONFIG:= \
+ CONFIG_6LOWPAN=m \
+ CONFIG_BT_6LOWPAN=m
+ FILES:= \
+ $(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko \
+ $(LINUX_DIR)/net/6lowpan/6lowpan.ko
+ AUTOLOAD:=$(call AutoProbe,bluetooth)
+endef
+
+define KernelPackage/bluetooth_6lowpan/description
+ Kernel support for 6LoWPAN over Bluetooth Low Energy devices
+endef
+
+$(eval $(call KernelPackage,bluetooth_6lowpan))
+
+
define KernelPackage/bluetooth-hci-h4p
SUBMENU:=$(OTHER_MENU)
TITLE:=HCI driver with H4 Nokia extensions