aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-02-19 12:43:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-02-19 12:43:59 +0000
commiteb8d84e896a6aa9e74efc9c3a783c23cc5bc93ff (patch)
tree27155ec2bb3ddc4a6be8088203bb03abac6e1605
parent8dfd4cba5f7dd426fe053c7b98c1ef565bd317ff (diff)
downloadmaster-187ad058-eb8d84e896a6aa9e74efc9c3a783c23cc5bc93ff.tar.gz
master-187ad058-eb8d84e896a6aa9e74efc9c3a783c23cc5bc93ff.tar.bz2
master-187ad058-eb8d84e896a6aa9e74efc9c3a783c23cc5bc93ff.zip
[kernel] update to 2.6.37.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25577 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-2.6.37/060-block2mtd_init.patch2
-rw-r--r--target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch2
-rw-r--r--target/linux/generic/patches-2.6.37/980-vm_exports.patch2
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/omap24xx/Makefile2
-rw-r--r--target/linux/orion/Makefile2
-rw-r--r--target/linux/realview/Makefile2
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/xburst/Makefile2
10 files changed, 11 insertions, 11 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 3b91203a24..31ac5d0630 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -20,8 +20,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.36.2)
LINUX_KERNEL_MD5SUM:=d465f8ba05bf1b7530c596f1cca658e7
endif
-ifeq ($(LINUX_VERSION),2.6.37)
- LINUX_KERNEL_MD5SUM:=c8ee37b4fdccdb651e0603d35350b434
+ifeq ($(LINUX_VERSION),2.6.37.1)
+ LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/generic/patches-2.6.37/060-block2mtd_init.patch b/target/linux/generic/patches-2.6.37/060-block2mtd_init.patch
index 2af46a9650..18f0c4e512 100644
--- a/target/linux/generic/patches-2.6.37/060-block2mtd_init.patch
+++ b/target/linux/generic/patches-2.6.37/060-block2mtd_init.patch
@@ -105,7 +105,7 @@
{
--- a/fs/partitions/check.c
+++ b/fs/partitions/check.c
-@@ -707,6 +707,7 @@ rescan:
+@@ -715,6 +715,7 @@ rescan:
kfree(state);
return 0;
}
diff --git a/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch b/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
index 45a096d873..3725b922ce 100644
--- a/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
+++ b/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
@@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1388,3 +1389,5 @@ MODULE_LICENSE("GPL");
+@@ -1392,3 +1393,5 @@ MODULE_LICENSE("GPL");
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");
diff --git a/target/linux/generic/patches-2.6.37/980-vm_exports.patch b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
index 35b9b925fb..8d8638be31 100644
--- a/target/linux/generic/patches-2.6.37/980-vm_exports.patch
+++ b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
@@ -76,7 +76,7 @@
* macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c
+++ b/kernel/sched.c
-@@ -4773,6 +4773,7 @@ int can_nice(const struct task_struct *p
+@@ -4776,6 +4776,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
capable(CAP_SYS_NICE));
}
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index e74d386917..32e193ecce 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:=
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
index f64d67654d..9abc88e4a6 100644
--- a/target/linux/omap24xx/Makefile
+++ b/target/linux/omap24xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
MAINTAINER:=Michael Buesch <mb@bu3sch.de>
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
define Target/Description
TI OMAP-24xx
diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
index 2dc5d2530c..a2dd84bb00 100644
--- a/target/linux/orion/Makefile
+++ b/target/linux/orion/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index 4dabb4905a..00b7a331a9 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=ARM Ltd. Realview board (qemu)
FEATURES:=squashfs jffs2 fpu
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 22951147c7..2c039f4f23 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext4 audio
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 8e8888e8ff..c58242a1be 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=jffs2 targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526 id800wt
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
DEVICE_TYPE=other