aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-16 07:05:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-16 07:05:30 +0000
commiteb03a1d7c2c25e52e69086d0b0c8abb3bfe2f954 (patch)
tree0baace2d2c6977d75bc3094b75648e7f119f4f11
parentccc7fc226c86369f9ec259d1d7dd02c95737c950 (diff)
downloadmaster-187ad058-eb03a1d7c2c25e52e69086d0b0c8abb3bfe2f954.tar.gz
master-187ad058-eb03a1d7c2c25e52e69086d0b0c8abb3bfe2f954.tar.bz2
master-187ad058-eb03a1d7c2c25e52e69086d0b0c8abb3bfe2f954.zip
x86: merge all geode based subtargets into one
Build all geode platform drivers into the kernel Remove kmod-* packages for these drivers Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44809 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/x86/Makefile3
-rw-r--r--target/linux/x86/alix2/base-files/etc/config/network28
-rw-r--r--target/linux/x86/alix2/base-files/etc/config/system29
-rw-r--r--target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot13
-rw-r--r--target/linux/x86/alix2/config-default29
-rw-r--r--target/linux/x86/alix2/target.mk32
-rw-r--r--target/linux/x86/config-3.182
-rw-r--r--target/linux/x86/generic/profiles/Soekris45xx.mk16
-rw-r--r--target/linux/x86/generic/profiles/Soekris48xx.mk16
-rw-r--r--target/linux/x86/generic/profiles/Wrap.mk16
-rw-r--r--target/linux/x86/geode/config-default58
-rw-r--r--target/linux/x86/geode/target.mk14
-rw-r--r--target/linux/x86/geos/base-files/etc/config/network53
-rw-r--r--target/linux/x86/geos/base-files/etc/config/system30
-rw-r--r--target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot13
-rw-r--r--target/linux/x86/geos/config-default24
-rw-r--r--target/linux/x86/geos/target.mk34
-rw-r--r--target/linux/x86/modules.mk308
-rw-r--r--target/linux/x86/net5501/base-files/etc/config/network26
-rw-r--r--target/linux/x86/net5501/base-files/etc/config/system16
-rw-r--r--target/linux/x86/net5501/base-files/etc/hotplug.d/button/50-reboot13
-rw-r--r--target/linux/x86/net5501/config-default22
-rw-r--r--target/linux/x86/net5501/target.mk33
-rw-r--r--target/linux/x86/thincan/base-files/etc/init.d/alsa9
-rw-r--r--target/linux/x86/thincan/config-default15
-rw-r--r--target/linux/x86/thincan/profiles/dbe61.mk25
-rw-r--r--target/linux/x86/thincan/target.mk35
27 files changed, 74 insertions, 838 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 396d483c0a..b5164d81ec 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -10,8 +10,7 @@ ARCH:=i386
BOARD:=x86
BOARDNAME:=x86
FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
- rdc
+SUBTARGETS=generic olpc xen_domu ep80579 geode kvm_guest rdc
KERNEL_PATCHVER:=3.18
diff --git a/target/linux/x86/alix2/base-files/etc/config/network b/target/linux/x86/alix2/base-files/etc/config/network
deleted file mode 100644
index 4683402843..0000000000
--- a/target/linux/x86/alix2/base-files/etc/config/network
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright (C) 2011 OpenWrt.org
-
-config interface loopback
- option ifname lo
- option proto static
- option ipaddr 127.0.0.1
- option netmask 255.0.0.0
-
-# N.B. the labels on the Netgate boxes actually reverse the LAN and WAN
-# port markings.
-config interface lan
- option ifname eth1
- option type bridge
- option proto static
- option ipaddr 192.168.1.1
- option netmask 255.255.255.0
- option ip6assign 60
-
-config interface wan
- option ifname eth0
- option proto dhcp
-
-config interface wan6
- option ifname eth0
- option proto dhcpv6
-
-config globals globals
- option ula_prefix auto
diff --git a/target/linux/x86/alix2/base-files/etc/config/system b/target/linux/x86/alix2/base-files/etc/config/system
deleted file mode 100644
index 473586e29a..0000000000
--- a/target/linux/x86/alix2/base-files/etc/config/system
+++ /dev/null
@@ -1,29 +0,0 @@
-config system
- option hostname OpenWrt
- option timezone UTC
-
-config timeserver ntp
- list server 0.openwrt.pool.ntp.org
- list server 1.openwrt.pool.ntp.org
- list server 2.openwrt.pool.ntp.org
- list server 3.openwrt.pool.ntp.org
-
-config led
- option default 1
- option name LAN
- option sysfs 'alix:1'
- option trigger netdev
- option mode 'tx rx'
- option dev 'br-lan'
-
-config led
- option default 1
- option name WiFi
- option sysfs 'alix:2'
- option trigger 'phy0tpt'
-
-config led
- option default 0
- option name Heartbeat
- option sysfs 'alix:3'
- option trigger 'heartbeat'
diff --git a/target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot b/target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot
deleted file mode 100644
index bf893c15bb..0000000000
--- a/target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-logger -t button -p daemon.info "$BUTTON/$ACTION"
-
-case "$BUTTON/$ACTION" in
-
-reset/released)
- reboot -f
- ;;
-
-esac
-
-exit 0
diff --git a/target/linux/x86/alix2/config-default b/target/linux/x86/alix2/config-default
deleted file mode 100644
index e7b4f264c0..0000000000
--- a/target/linux/x86/alix2/config-default
+++ /dev/null
@@ -1,29 +0,0 @@
-CONFIG_ALIX=y
-CONFIG_DEBUG_BUGVERBOSE=y
-CONFIG_DMI=y
-CONFIG_DMIID=y
-CONFIG_DMI_SCAN_MACHINE_NON_EFI_FALLBACK=y
-# CONFIG_DMI_SYSFS is not set
-# CONFIG_GEOS is not set
-CONFIG_GPIOLIB=y
-CONFIG_GPIO_DEVRES=y
-# CONFIG_GPIO_F7188X is not set
-# CONFIG_GPIO_INTEL_MID is not set
-CONFIG_GPIO_SYSFS=y
-# CONFIG_HIGHMEM64G is not set
-CONFIG_HWMON=y
-# CONFIG_KEYBOARD_GPIO is not set
-# CONFIG_LEDS_CLEVO_MAIL is not set
-# CONFIG_M486 is not set
-# CONFIG_MATH_EMULATION is not set
-CONFIG_MGEODE_LX=y
-CONFIG_NLS=y
-CONFIG_PATA_CS5536=y
-CONFIG_PCI_LABEL=y
-# CONFIG_SCx200 is not set
-CONFIG_THERMAL_HWMON=y
-CONFIG_X86_CMOV=y
-CONFIG_X86_DEBUGCTLMSR=y
-CONFIG_X86_TSC=y
-CONFIG_X86_USE_3DNOW=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
deleted file mode 100644
index b5d011753f..0000000000
--- a/target/linux/x86/alix2/target.mk
+++ /dev/null
@@ -1,32 +0,0 @@
-BOARDNAME:=PCEngines alix2
-FEATURES:=squashfs ext4 pci usb gpio
-DEFAULT_PACKAGES += \
- kmod-crypto-hw-geode kmod-crypto-ocf kmod-crypto-aes kmod-crypto-cbc \
- kmod-gpio-cs5535-new kmod-gpio-nsc \
- kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
- kmod-cs5536 \
- kmod-hwmon-core kmod-hwmon-lm90 \
- kmod-via-rhine \
- kmod-i2c-core kmod-i2c-gpio \
- kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
- kmod-i2c-scx200-acb \
- kmod-usb-core kmod-usb2 kmod-usb2-pci kmod-usb-ohci \
- kmod-cfg80211 kmod-mac80211 \
- kmod-mppe kmod-pppoe kmod-pppol2tp \
- kmod-ath5k kmod-ath9k \
- kmod-leds-gpio kmod-input-gpio-keys-polled \
- kmod-button-hotplug \
- kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
- kmod-ledtrig-netdev \
- kmod-cpu-msr hwclock wpad
-CS5535_MASK:=0x0b000042
-
-CPU_TYPE := geode
-
-define Target/Description
- Build firmware images for PCEngines alix2 board
-endef
-
-define KernelPackage/gpio-cs5535-new/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
-endef
diff --git a/target/linux/x86/config-3.18 b/target/linux/x86/config-3.18
index 3bcecc43ec..d7a2d61539 100644
--- a/target/linux/x86/config-3.18
+++ b/target/linux/x86/config-3.18
@@ -404,7 +404,7 @@ CONFIG_X86_MCE_INTEL=y
CONFIG_X86_MCE_THRESHOLD=y
CONFIG_X86_MINIMUM_CPU_FAMILY=4
CONFIG_X86_MPPARSE=y
-# CONFIG_X86_MSR is not set
+CONFIG_X86_MSR=y
# CONFIG_X86_P4_CLOCKMOD is not set
# CONFIG_X86_PAE is not set
CONFIG_X86_PAT=y
diff --git a/target/linux/x86/generic/profiles/Soekris45xx.mk b/target/linux/x86/generic/profiles/Soekris45xx.mk
deleted file mode 100644
index d1d88c6fca..0000000000
--- a/target/linux/x86/generic/profiles/Soekris45xx.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Soekris45xx
- NAME:=Soekris Net45xx
- PACKAGES:=kmod-natsemi kmod-leds-net48xx kmod-wdt-sc520
-endef
-
-define Profile/Soekris45xx/Description
- Package set compatible with the Soekris Net45xx. Net4511 and 4521 need PCMCIA Cardbus support. Please add manually.
-endef
-$(eval $(call Profile,Soekris45xx))
diff --git a/target/linux/x86/generic/profiles/Soekris48xx.mk b/target/linux/x86/generic/profiles/Soekris48xx.mk
deleted file mode 100644
index 66bafbfe47..0000000000
--- a/target/linux/x86/generic/profiles/Soekris48xx.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Soekris48xx
- NAME:=Soekris Net48xx
- PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-net48xx kmod-gpio-scx200 kmod-wdt-scx200 kmod-hwmon-pc87360
-endef
-
-define Profile/Soekris48xx/Description
- Package set compatible with the Soekris Net4801. Contains I2C/LEDS/GPIO/Sensors support
-endef
-$(eval $(call Profile,Soekris48xx))
diff --git a/target/linux/x86/generic/profiles/Wrap.mk b/target/linux/x86/generic/profiles/Wrap.mk
deleted file mode 100644
index 62532ac828..0000000000
--- a/target/linux/x86/generic/profiles/Wrap.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2006,2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Wrap
- NAME:=PCEngines WRAP
- PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-wrap kmod-gpio-scx200 kmod-wdt-scx200 kmod-hwmon-pc87360
-endef
-
-define Profile/Wrap/Description
- Package set compatible with the PCEngines WRAP. Contains I2C/LEDS/GPIO/Sensors support
-endef
-$(eval $(call Profile,Wrap))
diff --git a/target/linux/x86/geode/config-default b/target/linux/x86/geode/config-default
new file mode 100644
index 0000000000..af22d102d7
--- /dev/null
+++ b/target/linux/x86/geode/config-default
@@ -0,0 +1,58 @@
+CONFIG_ALIX=y
+# CONFIG_ATA_PIIX is not set
+CONFIG_CS5535_CLOCK_EVENT_SRC=y
+CONFIG_CS5535_MFGPT=y
+CONFIG_CS5535_MFGPT_DEFAULT_IRQ=7
+CONFIG_GEODE_WDT=y
+CONFIG_GPIOLIB=y
+CONFIG_GPIO_CS5535=y
+CONFIG_GPIO_DEVRES=y
+# CONFIG_GPIO_F7188X is not set
+# CONFIG_GPIO_INTEL_MID is not set
+CONFIG_GPIO_SYSFS=y
+# CONFIG_HIGHMEM64G is not set
+CONFIG_HWMON=y
+CONFIG_I2C=y
+CONFIG_I2C_ALGOBIT=y
+CONFIG_I2C_ALGOPCA=y
+CONFIG_I2C_ALGOPCF=y
+CONFIG_I2C_BOARDINFO=y
+# CONFIG_KEYBOARD_GPIO is not set
+CONFIG_LEDS_GPIO=y
+# CONFIG_M486 is not set
+CONFIG_MFD_CORE=y
+CONFIG_MFD_CS5535=y
+CONFIG_MGEODE_LX=y
+CONFIG_NATSEMI=y
+CONFIG_NET5501=y
+CONFIG_NLS=y
+CONFIG_NSC_GPIO=y
+CONFIG_PATA_CS5520=y
+CONFIG_PATA_CS5530=y
+CONFIG_PATA_CS5535=y
+CONFIG_PATA_CS5536=y
+CONFIG_PATA_SC1200=y
+CONFIG_PC8736x_GPIO=y
+CONFIG_SC1200_WDT=y
+CONFIG_SCx200_ACB=y
+CONFIG_SCx200_WDT=y
+CONFIG_SENSORS_LM90=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+CONFIG_USB_EHCI_HCD=y
+# CONFIG_USB_EHCI_HCD_PLATFORM is not set
+CONFIG_USB_EHCI_PCI=y
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_HCD_PCI=y
+# CONFIG_USB_OHCI_HCD_PLATFORM is not set
+# CONFIG_USB_UHCI_HCD is not set
+CONFIG_VIA_RHINE=y
+CONFIG_VIA_RHINE_MMIO=y
+CONFIG_X86_CMOV=y
+CONFIG_X86_CPUID=y
+CONFIG_X86_DEBUGCTLMSR=y
+# CONFIG_X86_MCE is not set
+CONFIG_X86_REBOOTFIXUPS=y
+CONFIG_X86_TSC=y
+CONFIG_X86_USE_3DNOW=y
+CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/geode/target.mk b/target/linux/x86/geode/target.mk
new file mode 100644
index 0000000000..57ccdc6c86
--- /dev/null
+++ b/target/linux/x86/geode/target.mk
@@ -0,0 +1,14 @@
+BOARDNAME:=AMD Geode based systems
+FEATURES:=squashfs ext4 pci usb gpio
+DEFAULT_PACKAGES += \
+ kmod-crypto-hw-geode kmod-crypto-ocf kmod-crypto-aes kmod-crypto-cbc \
+ kmod-ath5k kmod-ath9k \
+ kmod-button-hotplug \
+ kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
+ kmod-ledtrig-netdev hwclock wpad-mini
+
+CPU_TYPE := geode
+
+define Target/Description
+ Build firmware images for AMD Geode GX/LX based systems (net5501, alix, geos)
+endef
diff --git a/target/linux/x86/geos/base-files/etc/config/network b/target/linux/x86/geos/base-files/etc/config/network
deleted file mode 100644
index d12d528032..0000000000
--- a/target/linux/x86/geos/base-files/etc/config/network
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright (C) 2011 OpenWrt.org
-
-config interface loopback
- option ifname lo
- option proto static
- option ipaddr 127.0.0.1
- option netmask 255.0.0.0
-
-config interface lan
- option ifname "eth0 eth1"
- option type bridge
- option proto static
- option ipaddr 192.168.1.1
- option netmask 255.255.255.0
- option ip6assign 60
-
-config atm-bridge
- option unit 0
- option atmdev 0
- option vpi 0
- option vci 35
- option encaps llc
- option payload bridged
- option sendsize 2040
-
-config interface wan
- option proto dhcp
- option ifname nas0
- # clone your eth0 address here
- # option macaddr '00:0A:FA:22:00:80'
-
-config interface wan6
- option ifname nas0
- option proto dhcpv6
-
-config globals globals
- option ula_prefix auto
-
-
-# 2nd interface on Geos2
-#config interface wan
-# option proto pppoa
-# option atmdev 1
-# option vpi 8
-# option vci 32
-# option encaps vc
-# option username 'username@myisp.net'
-# option password 'password'
-# option keepalive 3
-# option defaultroute 1
-# option peerdns 1
-# option pppd_options 'kdebug 1 debug noccp'
-
diff --git a/target/linux/x86/geos/base-files/etc/config/system b/target/linux/x86/geos/base-files/etc/config/system
deleted file mode 100644
index 988c849ec1..0000000000
--- a/target/linux/x86/geos/base-files/etc/config/system
+++ /dev/null
@@ -1,30 +0,0 @@
-
-config system
- option hostname OpenWrt
- option timezone UTC
-
-config timeserver ntp
- list server 0.openwrt.pool.ntp.org
- list server 1.openwrt.pool.ntp.org
- list server 2.openwrt.pool.ntp.org
- list server 3.openwrt.pool.ntp.org
-
-config led
- option default 0
- option name LAN
- option sysfs 'geos:1'
- option trigger netdev
- option mode 'tx rx'
- option dev 'br-lan'
-
-config led
- option default 0
- option name WiFi
- option sysfs 'geos:2'
- option trigger 'phy0tpt'
-
-config led
- option default 0
- option name Health
- option sysfs 'geos:3'
- option trigger 'heartbeat'
diff --git a/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot b/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot
deleted file mode 100644
index bf893c15bb..0000000000
--- a/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-logger -t button -p daemon.info "$BUTTON/$ACTION"
-
-case "$BUTTON/$ACTION" in
-
-reset/released)
- reboot -f
- ;;
-
-esac
-
-exit 0
diff --git a/target/linux/x86/geos/config-default b/target/linux/x86/geos/config-default
deleted file mode 100644
index 66ae2c7afc..0000000000
--- a/target/linux/x86/geos/config-default
+++ /dev/null
@@ -1,24 +0,0 @@
-# CONFIG_ATA_PIIX is not set
-CONFIG_DMI=y
-CONFIG_DMIID=y
-# CONFIG_DMI_SYSFS is not set
-CONFIG_GEOS=y
-CONFIG_GPIOLIB=y
-CONFIG_GPIO_SYSFS=y
-# CONFIG_HIGHMEM64G is not set
-CONFIG_HWMON=y
-# CONFIG_ISDN is not set
-# CONFIG_LEDS_CLEVO_MAIL is not set
-# CONFIG_M486 is not set
-# CONFIG_MATH_EMULATION is not set
-CONFIG_MGEODE_LX=y
-CONFIG_NLS=y
-CONFIG_PATA_CS5536=y
-CONFIG_PCI_LABEL=y
-# CONFIG_SCx200 is not set
-CONFIG_THERMAL_HWMON=y
-CONFIG_X86_CMOV=y
-CONFIG_X86_DEBUGCTLMSR=y
-CONFIG_X86_TSC=y
-CONFIG_X86_USE_3DNOW=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
deleted file mode 100644
index 5c265749f5..0000000000
--- a/target/linux/x86/geos/target.mk
+++ /dev/null
@@ -1,34 +0,0 @@
-BOARDNAME:=Traverse Geos
-FEATURES:=squashfs ext4 pci usb gpio broken
-DEFAULT_PACKAGES += \
- kmod-crypto-hw-geode kmod-crypto-ocf \
- kmod-gpio-cs5535-new kmod-gpio-nsc \
- kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
- kmod-cs5536 \
- kmod-hwmon-core kmod-hwmon-lm90 \
- kmod-8139cp kmod-solos-pci kmod-sched \
- kmod-i2c-core kmod-i2c-gpio \
- kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
- kmod-i2c-scx200-acb \
- kmod-usb-core kmod-usb2-pci kmod-usb-ohci \
- kmod-cfg80211 kmod-mac80211 \
- kmod-mppe kmod-pppoa kmod-pppol2tp \
- kmod-ath5k kmod-ath9k \
- kmod-leds-gpio kmod-input-gpio-keys-polled \
- kmod-button-hotplug \
- kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
- kmod-ledtrig-netdev \
- kmod-cpu-msr \
- soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
- hwclock wpad flashrom tc
-CS5535_MASK:=0x0E000048
-
-CPU_TYPE := geode
-
-define Target/Description
- Build firmware images for Traverse Geos board
-endef
-
-define KernelPackage/gpio-cs5535-new/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
-endef
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index f8cb3a7c8f..3abe01742b 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -5,314 +5,6 @@
# See /LICENSE for more information.
#
-define KernelPackage/cs5535
- SUBMENU:=$(BLOCK_MENU)
- TITLE:=NSC/AMD CS5535 chipset support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_BLK_DEV_CS5535
- FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
- AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
- $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5535/description
- Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,cs5535))
-
-
-define KernelPackage/cs5536
- SUBMENU:=$(BLOCK_MENU)
- TITLE:=AMD CS5536 chipset support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_BLK_DEV_CS5536
- FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
- AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
- $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5536/description
- Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,cs5536))
-
-
-define KernelPackage/pata-cs5535
- SUBMENU:=$(BLOCK_MENU)
- TITLE:=CS5535 PATA support
- DEPENDS:=@TARGET_x86 @PCI_SUPPORT
- KCONFIG:=CONFIG_PATA_CS5535
- FILES=$(LINUX_DIR)/drivers/ata/pata_cs5535.ko
- AUTOLOAD:=$(call AutoLoad,30,pata_cs5535,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/pata-cs5535/description
- Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5535))
-
-
-define KernelPackage/pata-cs5536
- SUBMENU:=$(BLOCK_MENU)
- TITLE:=CS5536 PATA support
- DEPENDS:=@TARGET_x86 @PCI_SUPPORT
- KCONFIG:=CONFIG_PATA_CS5536
- FILES=$(LINUX_DIR)/drivers/ata/pata_cs5536.ko
- AUTOLOAD:=$(call AutoLoad,30,pata_cs5536,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/pata-cs5536/description
- Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5536))
-
-
-define KernelPackage/cpu-msr
- SUBMENU:=$(OTHER_MENU)
- TITLE:=x86 CPU MSR support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_X86_MSR
- FILES:=$(LINUX_DIR)/arch/x86/kernel/msr.ko
- AUTOLOAD:=$(call AutoLoad,20,msr)
-endef
-
-define KernelPackage/cpu-msr/description
- Kernel module for Model Specific Registers support in x86 CPUs
-endef
-
-$(eval $(call KernelPackage,cpu-msr))
-
-define KernelPackage/gpio-cs5535-new
- SUBMENU:=$(OTHER_MENU)
- TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
- DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
- KCONFIG:=CONFIG_GPIO_CS5535
- FILES:=$(LINUX_DIR)/drivers/gpio/gpio-cs5535.ko
- AUTOLOAD:=$(call AutoLoad,50,gpio-cs5535)
-endef
-
-define KernelPackage/gpio-cs5535-new/description
- This package contains the new AMD CS5535/CS5536 GPIO driver
-endef
-
-$(eval $(call KernelPackage,gpio-cs5535-new))
-
-define KernelPackage/gpio-nsc
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Natsemi GPIO support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_NSC_GPIO
- FILES:=$(LINUX_DIR)/drivers/char/nsc_gpio.ko
- AUTOLOAD:=$(call AutoLoad,40,nsc_gpio)
-endef
-
-define KernelPackage/gpio-nsc/description
- Kernel module for Natsemi GPIO
-endef
-
-$(eval $(call KernelPackage,gpio-nsc))
-
-
-define KernelPackage/gpio-pc8736x
- SUBMENU:=$(OTHER_MENU)
- TITLE:=PC8736x GPIO support
- DEPENDS:=@TARGET_x86 +kmod-gpio-nsc
- KCONFIG:=CONFIG_PC8736x_GPIO
- FILES:=$(LINUX_DIR)/drivers/char/pc8736x_gpio.ko
- AUTOLOAD:=$(call AutoLoad,40,pc8736x_gpio)
-endef
-
-define KernelPackage/gpio-pc8736x/description
- Kernel module for PC8736x GPIO
-endef
-
-$(eval $(call KernelPackage,gpio-pc8736x))
-
-
-define KernelPackage/gpio-scx200
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Natsemi SCX200 GPIO support
- DEPENDS:=@TARGET_x86 +kmod-gpio-nsc
- KCONFIG:=CONFIG_SCx200_GPIO
- FILES:=$(LINUX_DIR)/drivers/char/scx200_gpio.ko
- AUTOLOAD:=$(call AutoLoad,50,scx200_gpio)
-endef
-
-define KernelPackage/gpio-scx200/description
- Kernel module for SCX200 GPIO
-endef
-
-$(eval $(call KernelPackage,gpio-scx200))
-
-define KernelPackage/wdt-geode
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Geode/LX Watchdog timer
- DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
- KCONFIG:=CONFIG_GEODE_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/geodewdt.ko
- AUTOLOAD:=$(call AutoLoad,50,geodewdt)
-endef
-
-define KernelPackage/wdt-geode/description
- Kernel module for Geode watchdog timer.
-endef
-
-$(eval $(call KernelPackage,wdt-geode))
-
-
-define KernelPackage/cs5535-clockevt
- SUBMENU:=$(OTHER_MENU)
- TITLE:=CS5535/CS5536 high-res timer (MFGPT) events
- DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
- KCONFIG:=CONFIG_CS5535_CLOCK_EVENT_SRC
- FILES:=$(LINUX_DIR)/drivers/clocksource/cs5535-clockevt.ko
- AUTOLOAD:=$(call AutoLoad,50,cs5535-clockevt)
-endef
-
-define KernelPackage/cs5535-clockevt/description
- Kernel module for CS5535/6 high-res clock event source
-endef
-
-$(eval $(call KernelPackage,cs5535-clockevt))
-
-
-define KernelPackage/cs5535-mfgpt
- SUBMENU:=$(OTHER_MENU)
- TITLE:=CS5535/6 Multifunction General Purpose Timer
- DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
- KCONFIG:=CONFIG_CS5535_MFGPT
- FILES:=$(LINUX_DIR)/drivers/misc/cs5535-mfgpt.ko
- AUTOLOAD:=$(call AutoLoad,45,cs5535-mfgpt)
-endef
-
-define KernelPackage/cs5535-mfgpt/description
- Kernel module for CS5535/6 multifunction general purpose timer.
-endef
-
-$(eval $(call KernelPackage,cs5535-mfgpt))
-
-
-define KernelPackage/cs5535-mfd
- SUBMENU:=$(OTHER_MENU)
- TITLE:=CS5535/6 Multifunction General Purpose Driver
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_MFD_CS5535
- FILES:= \
- $(LINUX_DIR)/drivers/mfd/mfd-core.ko \
- $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko
- AUTOLOAD:=$(call AutoLoad,44,mfd-core cs5535-mfd)
-endef
-
-define KernelPackage/cs5535-mfd/description
- Core driver for CS5535/CS5536 MFD functions.
-endef
-
-$(eval $(call KernelPackage,cs5535-mfd))
-
-define KernelPackage/wdt-sc520
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Natsemi SC520 Watchdog support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_SC520_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sc520_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,sc520_wdt)
-endef
-
-define KernelPackage/wdt-sc520/description
- Kernel module for SC520 Watchdog
-endef
-
-$(eval $(call KernelPackage,wdt-sc520))
-
-
-define KernelPackage/wdt-scx200
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Natsemi SCX200 Watchdog support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_SCx200_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/scx200_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,scx200_wdt)
-endef
-
-define KernelPackage/wdt-scx200/description
- Kernel module for SCX200 Watchdog
-endef
-
-$(eval $(call KernelPackage,wdt-scx200))
-
-I2C_SCX200_MODULES:=\
- CONFIG_SCx200_I2C:drivers/i2c/busses/scx200_i2c
-
-define KernelPackage/i2c-scx200
- $(call i2c_defaults,$(I2C_SCX200_MODULES),59)
- TITLE:=Geode SCx200 I2C using GPIO pins
- DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
- KCONFIG+= \
- CONFIG_SCx200_I2C_SCL=12 \
- CONFIG_SCx200_I2C_SDA=13
-endef
-
-define KernelPackage/i2c-scx200/description
- Kernel module for I2C using GPIO pins on the Geode SCx200 processors.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200))
-
-
-I2C_SCX200_ACB_MODULES:=\
- CONFIG_SCx200_ACB:drivers/i2c/busses/scx200_acb
-
-define KernelPackage/i2c-scx200-acb
- $(call i2c_defaults,$(I2C_SCX200_ACB_MODULES),59)
- TITLE:=Geode SCx200 ACCESS.bus support
- DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
-endef
-
-define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
- and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200-acb))
-
-
-define KernelPackage/leds-wrap
- SUBMENU:=$(LEDS_MENU)
- TITLE:=PCengines WRAP LED support
- DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
- KCONFIG:=CONFIG_LEDS_WRAP
- FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.ko
- AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
-endef
-
-define KernelPackage/leds-wrap/description
- Kernel module for PCengines WRAP LEDs
-endef
-
-$(eval $(call KernelPackage,leds-wrap))
-
-
-define KernelPackage/leds-net48xx
- SUBMENU:=$(LEDS_MENU)
- TITLE:=Soekris Net48xx LED support
- DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
- KCONFIG:=CONFIG_LEDS_NET48XX
- FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.ko
- AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
-endef
-
-define KernelPackage/leds-net48xx/description
- Kernel module for Soekris Net48xx LEDs
-endef
-
-$(eval $(call KernelPackage,leds-net48xx))
-
define KernelPackage/rdc321x-wdt
SUBMENU:=$(OTHER_MENU)
TITLE:=RDC321x watchdog
diff --git a/target/linux/x86/net5501/base-files/etc/config/network b/target/linux/x86/net5501/base-files/etc/config/network
deleted file mode 100644
index 4aa8096584..0000000000
--- a/target/linux/x86/net5501/base-files/etc/config/network
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright (C) 2011 OpenWrt.org
-
-config interface loopback
- option ifname lo
- option proto static
- option ipaddr 127.0.0.1
- option netmask 255.0.0.0
-
-config interface lan
- option ifname "eth1 eth2 eth3"
- option type bridge
- option proto static
- option ipaddr 192.168.1.1
- option netmask 255.255.255.0
- option ip6assign 60
-
-config interface wan
- option ifname eth0
- option proto dhcp
-
-config interface wan6
- option ifname eth0
- option proto dhcpv6
-
-config globals globals
- option ula_prefix auto
diff --git a/target/linux/x86/net5501/base-files/etc/config/system b/target/linux/x86/net5501/base-files/etc/config/system
deleted file mode 100644
index 5db7bc2424..0000000000
--- a/target/linux/x86/net5501/base-files/etc/config/system
+++ /dev/null
@@ -1,16 +0,0 @@
-config system
- option hostname OpenWrt
- option timezone UTC
-
-config timeserver ntp
- list server 0.openwrt.pool.ntp.org
- list server 1.openwrt.pool.ntp.org
- list server 2.openwrt.pool.ntp.org
- list server 3.openwrt.pool.ntp.org
-
-config led
- option default 1
- option name Heartbeat
- option sysfs 'net5501:1'
- option trigger heartbeat
-
diff --git a/target/linux/x86/net5501/base-files/etc/hotplug.d/button/50-reboot b/target/linux/x86/net5501/base-files/etc/hotplug.d/button/50-reboot
deleted file mode 100644
index bf893c15bb..0000000000
--- a/target/linux/x86/net5501/base-files/etc/hotplug.d/button/50-reboot
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-logger -t button -p daemon.info "$BUTTON/$ACTION"
-
-case "$BUTTON/$ACTION" in
-
-reset/released)
- reboot -f
- ;;
-
-esac
-
-exit 0
diff --git a/target/linux/x86/net5501/config-default b/target/linux/x86/net5501/config-default
deleted file mode 100644
index 8b3b28b035..0000000000
--- a/target/linux/x86/net5501/config-default
+++ /dev/null
@@ -1,22 +0,0 @@
-# CONFIG_ATA_PIIX is not set
-CONFIG_DEBUG_BUGVERBOSE=y
-CONFIG_GPIOLIB=y
-CONFIG_GPIO_DEVRES=y
-# CONFIG_GPIO_F7188X is not set
-# CONFIG_GPIO_INTEL_MID is not set
-CONFIG_GPIO_SYSFS=y
-# CONFIG_HIGHMEM64G is not set
-CONFIG_HWMON=y
-# CONFIG_ISDN is not set
-# CONFIG_KEYBOARD_GPIO is not set
-# CONFIG_M486 is not set
-# CONFIG_MATH_EMULATION is not set
-CONFIG_MGEODE_LX=y
-CONFIG_PATA_CS5536=y
-# CONFIG_SCx200 is not set
-CONFIG_THERMAL_HWMON=y
-CONFIG_X86_CMOV=y
-CONFIG_X86_DEBUGCTLMSR=y
-CONFIG_X86_TSC=y
-CONFIG_X86_USE_3DNOW=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/net5501/target.mk b/target/linux/x86/net5501/target.mk
deleted file mode 100644
index 5d46fe4f6e..0000000000
--- a/target/linux/x86/net5501/target.mk
+++ /dev/null
@@ -1,33 +0,0 @@
-BOARDNAME:=Soekris net5501
-FEATURES:=squashfs ext4 pci usb gpio
-DEFAULT_PACKAGES += kmod-crypto-hw-geode kmod-crypto-ocf \
- kmod-gpio-cs5535-new kmod-gpio-nsc \
- kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
- kmod-cs5536 \
- kmod-hwmon-core kmod-hwmon-pc87360 kmod-gpio-pc8736x \
- kmod-via-rhine kmod-solos-pci \
- kmod-i2c-core kmod-i2c-gpio \
- kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
- kmod-i2c-scx200-acb \
- kmod-usb-core kmod-usb2-pci kmod-usb-ohci \
- kmod-cfg80211 kmod-mac80211 \
- kmod-mppe kmod-pppoe kmod-pppoa kmod-pppol2tp \
- kmod-ath kmod-ath5k kmod-ath9k \
- kmod-leds-gpio kmod-input-gpio-keys-polled \
- kmod-button-hotplug \
- kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
- kmod-ledtrig-netdev \
- kmod-cpu-msr \
- hwclock wpad
-
-CS5535_MASK:=0x01000040
-
-CPU_TYPE := geode
-
-define Target/Description
- Build firmware images for Soekris net5501 board
-endef
-
-define KernelPackage/gpio-cs5535-new/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
-endef
diff --git a/target/linux/x86/thincan/base-files/etc/init.d/alsa b/target/linux/x86/thincan/base-files/etc/init.d/alsa
deleted file mode 100644
index 94c6965e7e..0000000000
--- a/target/linux/x86/thincan/base-files/etc/init.d/alsa
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-START=50
-
-start() {
- amixer set PCM 50% unmute
- amixer set Headphone 100% unmute
-}
-
diff --git a/target/linux/x86/thincan/config-default b/target/linux/x86/thincan/config-default
deleted file mode 100644
index 405c65b5fc..0000000000
--- a/target/linux/x86/thincan/config-default
+++ /dev/null
@@ -1,15 +0,0 @@
-CONFIG_8139TOO=y
-# CONFIG_8139TOO_8129 is not set
-# CONFIG_8139TOO_PIO is not set
-# CONFIG_8139TOO_TUNE_TWISTER is not set
-# CONFIG_8139_OLD_RX_RESET is not set
-CONFIG_BLK_DEV_NBD=y
-# CONFIG_EMBEDDED is not set
-CONFIG_IP_PNP=y
-# CONFIG_IP_PNP_BOOTP is not set
-CONFIG_IP_PNP_DHCP=y
-# CONFIG_IP_PNP_RARP is not set
-CONFIG_LOCKD=y
-CONFIG_NFS_FS=y
-CONFIG_ROOT_NFS=y
-CONFIG_SUNRPC=y
diff --git a/target/linux/x86/thincan/profiles/dbe61.mk b/target/linux/x86/thincan/profiles/dbe61.mk
deleted file mode 100644
index ee7c251a37..0000000000
--- a/target/linux/x86/thincan/profiles/dbe61.mk
+++ /dev/null
@@ -1,25 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DBE61
- NAME:=DBE61
-endef
-
-define Profile/DBE61/Description
- Compile OpenWrt for Artec ThinCan DBE61
-
- ThinCan DBE61 is a thin-client featuring:
- * AMD Geode LX700
- * AMD CS5535 companion device
- * 64MB or 256MB NAND Flash or none
- * 128MB or 256MB DDR SDRAM
- * Realtek RTL8139
-
- http://wiki.thincan.org/DBE61
-endef
-
-$(eval $(call Profile,DBE61))
diff --git a/target/linux/x86/thincan/target.mk b/target/linux/x86/thincan/target.mk
deleted file mode 100644
index 8081353957..0000000000
--- a/target/linux/x86/thincan/target.mk
+++ /dev/null
@@ -1,35 +0,0 @@
-DEVICE_TYPE:=terminal
-BOARDNAME:=Artec ThinCan
-CPU_TYPE := geode
-FEATURES += broken
-
-DEFAULT_PACKAGES:=\
- base-files \
- busybox \
- hotplug2 \
- libc \
- libgcc \
- opkg \
- uci \
- udevtrigger \
- kmod-fs-msdos \
- kmod-fs-vfat \
- kmod-fs-ext4 \
- kmod-usb-core \
- kmod-usb-ohci \
- kmod-usb-hid \
- kmod-usb-storage \
- kmod-usb2-pci \
- kmod-sound-core \
- kmod-sound-cs5535audio \
- kmod-crypto-core \
- kmod-crypto-hw-geode \
- kmod-crypto-ocf \
- kmod-crypto-aes
-
-define Target/Description
- Build firmware images for Artec ThinCan
-
- Note that NBD, NFS, DHCP and ethernet module are built into kernel
-endef
-