aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-06-21 16:53:07 +0000
committerJohn Crispin <blogic@openwrt.org>2013-06-21 16:53:07 +0000
commiteaa793238674be00376dc968b2b3c42d6b1d9e0b (patch)
tree2f2dd01364182672e4f457383440ef3feb42177f
parentd9da5fe22772d7ac7cf23382d588776d10e809ed (diff)
downloadmaster-187ad058-eaa793238674be00376dc968b2b3c42d6b1d9e0b.tar.gz
master-187ad058-eaa793238674be00376dc968b2b3c42d6b1d9e0b.tar.bz2
master-187ad058-eaa793238674be00376dc968b2b3c42d6b1d9e0b.zip
hostapd: remove old button hotplug script
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36991 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/services/hostapd/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 485a8fad0c..1c49451fa4 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -303,14 +303,9 @@ Package/hostapd-mini/install = $(Package/hostapd/install)
ifneq ($(LOCAL_TYPE),supplicant)
define Package/hostapd-utils/install
- $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
+ $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/rc.button
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
- $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
- $(if $(CONFIG_PROCD_INIT),
- $(INSTALL_DIR) $(1)/etc/rc.button/
- $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
- $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
- )
+ $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
endef
endif