aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2016-07-13 10:15:04 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-13 10:15:04 +0200
commite8c405b2048410f4c0fbc5e8a793bc6706e0e40e (patch)
tree3626da0f7ce551076f12d92f09dc6f9fee686621
parent858fc3b24b99915095a1c11255c6417bb8ebea34 (diff)
downloadmaster-187ad058-e8c405b2048410f4c0fbc5e8a793bc6706e0e40e.tar.gz
master-187ad058-e8c405b2048410f4c0fbc5e8a793bc6706e0e40e.tar.bz2
master-187ad058-e8c405b2048410f4c0fbc5e8a793bc6706e0e40e.zip
kernel: bump 4.1 to 4.1.27
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.1/492-try-auto-mounting-ubi0-rootfs-in-init-do_mounts.c.patch2
-rw-r--r--target/linux/generic/patches-4.1/494-mtd-ubi-add-EOF-marker-support.patch2
-rw-r--r--target/linux/generic/patches-4.1/811-pci_disable_usb_common_quirks.patch2
-rw-r--r--target/linux/generic/patches-4.1/820-usb_add_usb_find_device_by_name.patch2
5 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index b0e468559b..579bc701cd 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,11 +3,11 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .36
-LINUX_VERSION-4.1 = .23
+LINUX_VERSION-4.1 = .27
LINUX_VERSION-4.4 = .14
LINUX_KERNEL_MD5SUM-3.18.36 = 31b1699c1285aeeb81fb25750baa50d9
-LINUX_KERNEL_MD5SUM-4.1.23 = 5cb969fa874e110118722398b7c72c5d
+LINUX_KERNEL_MD5SUM-4.1.27 = 0347b5790c85bdabce41b8b9d9d4b98e
LINUX_KERNEL_MD5SUM-4.4.14 = 59e99c3bf5d495f1f95d26257962ca3e
ifdef KERNEL_PATCHVER
diff --git a/target/linux/generic/patches-4.1/492-try-auto-mounting-ubi0-rootfs-in-init-do_mounts.c.patch b/target/linux/generic/patches-4.1/492-try-auto-mounting-ubi0-rootfs-in-init-do_mounts.c.patch
index f6c71a2f63..c4a672c964 100644
--- a/target/linux/generic/patches-4.1/492-try-auto-mounting-ubi0-rootfs-in-init-do_mounts.c.patch
+++ b/target/linux/generic/patches-4.1/492-try-auto-mounting-ubi0-rootfs-in-init-do_mounts.c.patch
@@ -41,7 +41,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
#ifdef CONFIG_ROOT_NFS
#define NFSROOT_TIMEOUT_MIN 5
-@@ -532,6 +552,10 @@ void __init mount_root(void)
+@@ -532,6 +553,10 @@ void __init mount_root(void)
change_floppy("root floppy");
}
#endif
diff --git a/target/linux/generic/patches-4.1/494-mtd-ubi-add-EOF-marker-support.patch b/target/linux/generic/patches-4.1/494-mtd-ubi-add-EOF-marker-support.patch
index 14fae764fe..dd5ee306ef 100644
--- a/target/linux/generic/patches-4.1/494-mtd-ubi-add-EOF-marker-support.patch
+++ b/target/linux/generic/patches-4.1/494-mtd-ubi-add-EOF-marker-support.patch
@@ -41,7 +41,7 @@
break;
--- a/drivers/mtd/ubi/ubi.h
+++ b/drivers/mtd/ubi/ubi.h
-@@ -739,6 +739,7 @@ struct ubi_attach_info {
+@@ -741,6 +741,7 @@ struct ubi_attach_info {
int mean_ec;
uint64_t ec_sum;
int ec_count;
diff --git a/target/linux/generic/patches-4.1/811-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-4.1/811-pci_disable_usb_common_quirks.patch
index 6de4f6b9c7..e078b4e8aa 100644
--- a/target/linux/generic/patches-4.1/811-pci_disable_usb_common_quirks.patch
+++ b/target/linux/generic/patches-4.1/811-pci_disable_usb_common_quirks.patch
@@ -84,7 +84,7 @@
#endif /* __LINUX_USB_PCI_QUIRKS_H */
--- a/include/linux/usb/hcd.h
+++ b/include/linux/usb/hcd.h
-@@ -447,7 +447,14 @@ extern int usb_hcd_pci_probe(struct pci_
+@@ -448,7 +448,14 @@ extern int usb_hcd_pci_probe(struct pci_
extern void usb_hcd_pci_remove(struct pci_dev *dev);
extern void usb_hcd_pci_shutdown(struct pci_dev *dev);
diff --git a/target/linux/generic/patches-4.1/820-usb_add_usb_find_device_by_name.patch b/target/linux/generic/patches-4.1/820-usb_add_usb_find_device_by_name.patch
index 906f0e215e..6a16c5e7b4 100644
--- a/target/linux/generic/patches-4.1/820-usb_add_usb_find_device_by_name.patch
+++ b/target/linux/generic/patches-4.1/820-usb_add_usb_find_device_by_name.patch
@@ -74,7 +74,7 @@
* @dev: device the buffer will be used with
--- a/include/linux/usb.h
+++ b/include/linux/usb.h
-@@ -721,6 +721,7 @@ static inline bool usb_device_no_sg_cons
+@@ -720,6 +720,7 @@ static inline bool usb_device_no_sg_cons
return udev && udev->bus && udev->bus->no_sg_constraint;
}