aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-05-31 22:53:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-05-31 22:53:22 +0000
commite0d562138aac9f0670d936579a8d9e3736881339 (patch)
tree5c4508301b92516934f65dbccbfb34afe75b0eec
parent37ae50ee245fd8b3d0e3476af148ca8256717884 (diff)
downloadmaster-187ad058-e0d562138aac9f0670d936579a8d9e3736881339.tar.gz
master-187ad058-e0d562138aac9f0670d936579a8d9e3736881339.tar.bz2
master-187ad058-e0d562138aac9f0670d936579a8d9e3736881339.zip
ar71xx: create factory images for the WZR-HP-G30{0,1}NH boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27051 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 7ff7589d84..8e5bfa40dd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -137,6 +137,13 @@ define Image/Build/WZRHPG30XNH
echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
dd if=$(call imgname,$(1),$(2))-sysupgrade.bin; \
) > $(call imgname,$(1),$(2))-tftp.bin; \
+ buffalo-enc -p $(4) -v 1.76 \
+ -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+ -o $(KDIR)/$(2).enc; \
+ buffalo-tag -b $(4) -p $(4) -a ath -v 1.76 -m 1.01 -l mlang8 \
+ -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
+ -i $(KDIR)/$(2).enc \
+ -o $(call imgname,$(1),$(2))-factory.bin; \
fi; fi
endef
@@ -736,8 +743,8 @@ endef
wzrhpg300nh_cmdline=board=WZR-HP-G300NH console=ttyS0,115200
wzrhpg301nh_cmdline=board=WZR-HP-G301NH console=ttyS0,115200
define Image/Build/Profile/WZRHPG30XNH
- $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g300nh,$(wzrhpg300nh_cmdline))
- $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g301nh,$(wzrhpg301nh_cmdline))
+ $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g300nh,$(wzrhpg300nh_cmdline),WZR-HP-G300NH)
+ $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g301nh,$(wzrhpg301nh_cmdline),WZR-HP-G301NH)
endef
zcn1523h28_cmdline=board=ZCN-1523H-2 console=ttyS0,115200