aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-06-01 02:23:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-06-01 02:23:30 +0000
commitd45f8cb7f67d12d28d31fcd6061522587d191622 (patch)
tree1aa4222d1745561f37df6f7113e31edf4b488a65
parent7d86f5c1698fa37768bb1b0532f05e16cc6b0ea6 (diff)
downloadmaster-187ad058-d45f8cb7f67d12d28d31fcd6061522587d191622.tar.gz
master-187ad058-d45f8cb7f67d12d28d31fcd6061522587d191622.tar.bz2
master-187ad058-d45f8cb7f67d12d28d31fcd6061522587d191622.zip
ar71xx: add profile and image building code for wzr-hp-ag300h
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27076 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/generic/profiles/buffalo.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile6
2 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/buffalo.mk b/target/linux/ar71xx/generic/profiles/buffalo.mk
index 59ddd86cb3..5d9bab5406 100644
--- a/target/linux/ar71xx/generic/profiles/buffalo.mk
+++ b/target/linux/ar71xx/generic/profiles/buffalo.mk
@@ -15,3 +15,14 @@ define Profile/WZRHPG30XNH/Description
endef
$(eval $(call Profile,WZRHPG30XNH))
+
+define Profile/WZRHPAG300H
+ NAME:=Buffalo WZR-HP-AG300H
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-ohci kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG30XNH/Description
+ Package set optimized for the Buffalo WZR-HP-AG300H
+endef
+
+$(eval $(call Profile,WZRHPAG300H))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f13be29dcc..6c53795b42 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -780,6 +780,11 @@ define Image/Build/Profile/WZRHPG30XNH
$(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g301nh,$(wzrhpg301nh_cmdline),WZR-HP-G301NH)
endef
+wzrhpag300h_cmdline=board=WZR-HP-AG300H console=ttyS0,115200
+define Image/Build/Profile/WZRHPAG300H
+ $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-ag300h,$(wzrhpag300h_cmdline),WZR-HP-AG300H)
+endef
+
zcn1523h28_cmdline=board=ZCN-1523H-2 console=ttyS0,115200
define Image/Build/Profile/ZCN1523H28
$(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-2-8,$(zcn1523h28_cmdline))
@@ -833,6 +838,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WRT400N,$(1))
$(call Image/Build/Profile/WRT160NL,$(1))
$(call Image/Build/Profile/WZRHPG30XNH,$(1))
+ $(call Image/Build/Profile/WZRHPAG300H,$(1))
$(call Image/Build/Profile/ZCN1523H28,$(1))
$(call Image/Build/Profile/ZCN1523H516,$(1))
endef