aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-01-13 17:25:43 +0000
committerSteven Barth <steven@midlink.org>2013-01-13 17:25:43 +0000
commitc5752d0129a1fe61bf3ec588dfc37c5c2e815048 (patch)
tree63e2b535aed7200a7aaff964e1ba631b8c5ce560
parentae972de3fb204575f11e5130ab17a212cd949de7 (diff)
downloadmaster-187ad058-c5752d0129a1fe61bf3ec588dfc37c5c2e815048.tar.gz
master-187ad058-c5752d0129a1fe61bf3ec588dfc37c5c2e815048.tar.bz2
master-187ad058-c5752d0129a1fe61bf3ec588dfc37c5c2e815048.zip
ipv6-support: don't use disable_ipv6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35134 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/ipv6/ipv6-support/Makefile2
-rwxr-xr-xpackage/network/ipv6/ipv6-support/files/dhcpv6.sh5
2 files changed, 3 insertions, 4 deletions
diff --git a/package/network/ipv6/ipv6-support/Makefile b/package/network/ipv6/ipv6-support/Makefile
index 0d596d4d3b..74286e79b8 100644
--- a/package/network/ipv6/ipv6-support/Makefile
+++ b/package/network/ipv6/ipv6-support/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ipv6-support
-PKG_VERSION:=2013-01-02
+PKG_VERSION:=2013-01-13
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/ipv6-support/files/dhcpv6.sh b/package/network/ipv6/ipv6-support/files/dhcpv6.sh
index 9609f04d5c..5a668cd9b1 100755
--- a/package/network/ipv6/ipv6-support/files/dhcpv6.sh
+++ b/package/network/ipv6/ipv6-support/files/dhcpv6.sh
@@ -20,9 +20,8 @@ if [ "$state" == "started" ]; then
conf_set "$device" accept_ra 2
conf_set "$device" forwarding 2
- # Trigger RS
- conf_set "$device" disable_ipv6 1
- conf_set "$device" disable_ipv6 0
+ # Send RS on interface
+ [ -x /usr/sbin/6relayd ] && /usr/sbin/6relayd -s "$device"
exit 0
elif [ "$state" == "stopped" ]; then