aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:15 +0000
commitc4a45309960e1b4527d7ce2038c3908b0355c16d (patch)
treedb701254e9dcae2a7042f94795baf62ac1ccc5cb
parent46003ab374fad0ade4d8820d1539c2b887f6e0ea (diff)
downloadmaster-187ad058-c4a45309960e1b4527d7ce2038c3908b0355c16d.tar.gz
master-187ad058-c4a45309960e1b4527d7ce2038c3908b0355c16d.tar.bz2
master-187ad058-c4a45309960e1b4527d7ce2038c3908b0355c16d.zip
libroxml: add package (tiny XML parser/writer library)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39998 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/libs/libroxml/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/libs/libroxml/Makefile b/package/libs/libroxml/Makefile
new file mode 100644
index 0000000000..c591856f3b
--- /dev/null
+++ b/package/libs/libroxml/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libroxml
+PKG_VERSION:=2.3.0
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.libroxml.net/pool/v2.x
+PKG_MD5SUM:=a975f91be150f7a19168a45ce15769ca
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libroxml
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Minimum, easy-to-use, C implementation for xml file parsing
+ URL:=http://www.libroxml.net/
+endef
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --disable-xml-xpath-engine \
+ --disable-roxml
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libroxml/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libroxml.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libroxml))