aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:13 +0000
commitc3161b06c706b65d66d6ae443d4549fc942ebc97 (patch)
tree48ae9f9bef8745307bf8508b2eb1e83905ff64cb
parent795a8780e002e1993178d183d884b4ecd2a5363d (diff)
downloadmaster-187ad058-c3161b06c706b65d66d6ae443d4549fc942ebc97.tar.gz
master-187ad058-c3161b06c706b65d66d6ae443d4549fc942ebc97.tar.bz2
master-187ad058-c3161b06c706b65d66d6ae443d4549fc942ebc97.zip
ramips: do not rely on $(BIN_DIR) installed files during image build (for ubnt-erx)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48147 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 05d979573a..2427ac6d0f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -77,10 +77,10 @@ define Build/ubnt-erx-factory-compat
endef
define Build/ubnt-erx-factory-kernel
- if [ -e $(BIN_DIR)/$(KERNEL_INITRAMFS_IMAGE) ]; then \
- $(TAR) -rf $@ --transform='s/^.*/vmlinux.tmp/' $(BIN_DIR)/$(KERNEL_INITRAMFS_IMAGE); \
+ if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) ]; then \
+ $(TAR) -rf $@ --transform='s/^.*/vmlinux.tmp/' $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE); \
\
- md5sum --binary $(BIN_DIR)/$(KERNEL_INITRAMFS_IMAGE) | awk '{print $$1}'> $@.md5; \
+ md5sum --binary $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) | awk '{print $$1}'> $@.md5; \
$(TAR) -rf $@ --transform='s/^.*/vmlinux.tmp.md5/' $@.md5; \
$(RM) $@.md5; \
fi