aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-11-07 21:34:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-11-07 21:34:32 +0000
commitc20327d5ff0df0efc4b3a7f40a05ba08dd0190c8 (patch)
tree6f76f7580bb8b83b8bba18cae7841d58bb3dee3b
parent63a2c4b8e1e40530e3b403fc776ca7e9436a6437 (diff)
downloadmaster-187ad058-c20327d5ff0df0efc4b3a7f40a05ba08dd0190c8.tar.gz
master-187ad058-c20327d5ff0df0efc4b3a7f40a05ba08dd0190c8.tar.bz2
master-187ad058-c20327d5ff0df0efc4b3a7f40a05ba08dd0190c8.zip
ar71xx: change generated Buffalo firmware versions
With version 1.76 the upgrade may fail with newer Buffalo firmwares with a message like this: "You can not update the firmware because the firmware version is earlier than 1.82. Please use 1.82 or later version for firmware update." git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28815 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d687f6ff04..dbb8c174dc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -134,10 +134,10 @@ define Image/Build/WZRHPG30XNH
echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
dd if=$(call sysupname,$(1),$(2)); \
) > $(call imgname,$(1),$(2))-tftp.bin; \
- buffalo-enc -p $(4) -v 1.76 \
+ buffalo-enc -p $(4) -v 1.99 \
-i $(call sysupname,$(1),$(2)) \
-o $(KDIR)/$(2).enc; \
- buffalo-tag -b $(4) -p $(4) -a ath -v 1.76 -m 1.01 -l mlang8 \
+ buffalo-tag -b $(4) -p $(4) -a ath -v 1.99 -m 1.01 -l mlang8 \
-w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
-i $(KDIR)/$(2).enc \
-o $(call factoryname,$(1),$(2)); \
@@ -152,10 +152,10 @@ define Image/Build/WHRHPG300N
echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
dd if=$(call sysupname,$(1),$(2)); \
) > $(call imgname,$(1),$(2))-tftp.bin; \
- buffalo-enc -p $(5) -v 1.76 \
+ buffalo-enc -p $(5) -v 1.99 \
-i $(call sysupname,$(1),$(2)) \
-o $(KDIR)/$(2).enc; \
- buffalo-tag -b $(5) -p $(5) -a ath -v 1.76 -m 1.01 -l mlang8 \
+ buffalo-tag -b $(5) -p $(5) -a ath -v 1.99 -m 1.01 -l mlang8 \
-w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
-i $(KDIR)/$(2).enc \
-o $(call factoryname,$(1),$(2)); \