aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-30 17:09:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-30 17:09:22 +0000
commitba51da6a711908fd985b367e213910baed2676a7 (patch)
tree78a4c24cc2ae861e278b9ebfe4561d34196d8c35
parentf38b7b65581145f3ea4f53938d89f6ffaccc6168 (diff)
downloadmaster-187ad058-ba51da6a711908fd985b367e213910baed2676a7.tar.gz
master-187ad058-ba51da6a711908fd985b367e213910baed2676a7.tar.bz2
master-187ad058-ba51da6a711908fd985b367e213910baed2676a7.zip
create a package index
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4337 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Makefile1
-rw-r--r--package/Makefile3
2 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a23f478d7c..85091f618e 100644
--- a/Makefile
+++ b/Makefile
@@ -116,6 +116,7 @@ world: .config FORCE
$(MAKE) package/compile
$(MAKE) package/install
$(MAKE) target/install
+ $(MAKE) package/index
clean: FORCE
rm -rf build_* bin
diff --git a/package/Makefile b/package/Makefile
index 629ce88109..85f852fd54 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -55,3 +55,6 @@ install:
rm -rf $(BUILD_DIR)/root
$(MAKE) install-targets
+index: FORCE
+ (cd $(PACKAGE_DIR); $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages)
+