aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-17 10:47:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-17 10:47:10 +0000
commitb9dadc90b39f59bbf2229bd886b3551d88e67124 (patch)
tree09ea898e3658de6d2bbeb8425a037071ccf1b62d
parentaf3195f8c2b35b3ce99cdd91fea7c6676a8569e0 (diff)
downloadmaster-187ad058-b9dadc90b39f59bbf2229bd886b3551d88e67124.tar.gz
master-187ad058-b9dadc90b39f59bbf2229bd886b3551d88e67124.tar.bz2
master-187ad058-b9dadc90b39f59bbf2229bd886b3551d88e67124.zip
lantiq: Fixed brnImage signature for the VGV7510KW22BRN images
The old signature only worked because brnboot ignores the leading "5" in the signature. We can see the correct signature when flashing a brnImage via recovery web-interface, in this case brnboot reports: [CGI-Signature Check] buf:[BRNDA6431], sigInFlash:[BRNDA6431] Thanks to Mathias Kresin for reporting this. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48269 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/lantiq/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 553bdc17e6..f986d38642 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -417,7 +417,7 @@ Image/BuildKernel/Profile/VGV7510KW22NOR=$(call Image/BuildKernel/Template,VGV75
Image/Build/Profile/VGV7510KW22NOR=$(call Image/Build/$(1),$(1),VGV7510KW22NOR)
Image/BuildKernel/Profile/VGV7510KW22BRN=$(call Image/BuildKernel/Template,VGV7510KW22BRN,$(1))
-Image/Build/Profile/VGV7510KW22BRN=$(call Image/Build/$(1),$(1),VGV7510KW22BRN,5BRNDA6431,0x12345678,0x04c11db7,$(1))
+Image/Build/Profile/VGV7510KW22BRN=$(call Image/Build/$(1),$(1),VGV7510KW22BRN,BRNDA6431,0x12345678,0x04c11db7,$(1))
Image/BuildKernel/Profile/VGV7519NOR=$(call Image/BuildKernel/Template,VGV7519NOR,$(1))
Image/Build/Profile/VGV7519NOR=$(call Image/Build/$(1),$(1),VGV7519NOR)