aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-07-31 21:58:31 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-07-31 21:58:31 +0000
commitb24603ed1d323957541714aa6439d8789d7b0beb (patch)
treeee7b58bcf7ef7ac91b3d7f8060979a70bb3ff383
parentba6458136163ef7d17483335707e2a6aa22b8c54 (diff)
downloadmaster-187ad058-b24603ed1d323957541714aa6439d8789d7b0beb.tar.gz
master-187ad058-b24603ed1d323957541714aa6439d8789d7b0beb.tar.bz2
master-187ad058-b24603ed1d323957541714aa6439d8789d7b0beb.zip
packages: uboot-sunxi: bump to 2015.07
- switch to using kernel-supplied dtc - refresh olimex-a13-som and lamobo-r1 patches (compile-tested only) Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46540 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/boot/uboot-sunxi/Makefile8
-rw-r--r--package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch12
-rw-r--r--package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff277
-rw-r--r--package/boot/uboot-sunxi/patches/002-add-linksprite-pcduino.diff71
-rw-r--r--package/boot/uboot-sunxi/patches/003-add-lemaker-bananapro.diff22
-rw-r--r--package/boot/uboot-sunxi/patches/003-add-olimex-a13-som.diff19
-rw-r--r--package/boot/uboot-sunxi/patches/004-add-olimex-a13-som.diff71
-rw-r--r--package/boot/uboot-sunxi/patches/005-add-gmac-tx-delay-variant.patch24
-rw-r--r--package/boot/uboot-sunxi/patches/006-add-lamobo-r1.patch24
9 files changed, 313 insertions, 215 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 14ba922a17..1aeeceb9e0 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -6,15 +6,16 @@
#
include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=u-boot
-PKG_VERSION:=2015.01
+PKG_VERSION:=2015.07
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://mirror2.openwrt.org/sources \
ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=7f08dc9e98a71652bd6968888ed6ec95
+PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -132,7 +133,8 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
- CROSS_COMPILE=$(TARGET_CROSS)
+ CROSS_COMPILE=$(TARGET_CROSS) \
+ DTCDIR=$(LINUX_DIR)/scripts/dtc/
endef
define Package/uboot/install/default
diff --git a/package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch b/package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch
new file mode 100644
index 0000000000..afcb37c546
--- /dev/null
+++ b/package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch
@@ -0,0 +1,12 @@
+diff -ruN old/Makefile new/Makefile
+--- old/Makefile 2015-04-13 16:53:03.000000000 +0200
++++ new/Makefile 2015-07-31 15:52:08.920097812 +0200
+@@ -346,7 +346,7 @@
+ AWK = awk
+ PERL = perl
+ PYTHON = python
+-DTC = dtc
++DTC = $(DTCDIR)dtc
+ CHECK = sparse
+
+ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
diff --git a/package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff b/package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff
new file mode 100644
index 0000000000..5dd816c1a1
--- /dev/null
+++ b/package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff
@@ -0,0 +1,277 @@
+diff -ruN old/arch/arm/dts/Makefile new/arch/arm/dts/Makefile
+--- old/arch/arm/dts/Makefile 2015-07-14 19:32:21.000000000 +0200
++++ new/arch/arm/dts/Makefile 2015-07-31 23:23:33.518767858 +0200
+@@ -107,6 +107,7 @@
+ sun7i-a20-cubietruck.dtb \
+ sun7i-a20-hummingbird.dtb \
+ sun7i-a20-i12-tvbox.dtb \
++ sun7i-a20-lamobo-r1.dtb \
+ sun7i-a20-m3.dtb \
+ sun7i-a20-m5.dtb \
+ sun7i-a20-mk808c.dtb \
+diff -ruN old/arch/arm/dts/sun7i-a20-lamobo-r1.dts new/arch/arm/dts/sun7i-a20-lamobo-r1.dts
+--- old/arch/arm/dts/sun7i-a20-lamobo-r1.dts 1970-01-01 01:00:00.000000000 +0100
++++ new/arch/arm/dts/sun7i-a20-lamobo-r1.dts 2015-07-31 23:19:30.811206714 +0200
+@@ -0,0 +1,239 @@
++/*
++ * Copyright 2014 Hans de Goede <hdegoede@redhat.com>
++ *
++ * Hans de Goede <hdegoede@redhat.com>
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ * a) This file is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU General Public License as
++ * published by the Free Software Foundation; either version 2 of the
++ * License, or (at your option) any later version.
++ *
++ * This file is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public
++ * License along with this file; if not, write to the Free
++ * Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
++ * MA 02110-1301 USA
++ *
++ * Or, alternatively,
++ *
++ * b) Permission is hereby granted, free of charge, to any person
++ * obtaining a copy of this software and associated documentation
++ * files (the "Software"), to deal in the Software without
++ * restriction, including without limitation the rights to use,
++ * copy, modify, merge, publish, distribute, sublicense, and/or
++ * sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following
++ * conditions:
++ *
++ * The above copyright notice and this permission notice shall be
++ * included in all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "sun7i-a20.dtsi"
++#include "sunxi-common-regulators.dtsi"
++
++#include <dt-bindings/gpio/gpio.h>
++#include <dt-bindings/interrupt-controller/irq.h>
++#include <dt-bindings/pinctrl/sun4i-a10.h>
++
++/ {
++ model = "Lamobo R1";
++ compatible = "lamobo,lamobo-r1", "allwinner,sun7i-a20";
++
++ aliases {
++ serial0 = &uart0;
++ serial1 = &uart3;
++ serial2 = &uart7;
++ };
++
++ soc@01c00000 {
++ spi0: spi@01c05000 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&spi0_pins_a>;
++ status = "okay";
++ };
++
++ mmc0: mmc@01c0f000 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&mmc0_pins_a>, <&mmc0_cd_pin_bananapi>;
++ vmmc-supply = <&reg_vcc3v3>;
++ bus-width = <4>;
++ cd-gpios = <&pio 7 10 0>; /* PH10 */
++ cd-inverted;
++ status = "okay";
++ };
++
++ usbphy: phy@01c13400 {
++ usb1_vbus-supply = <&reg_usb1_vbus>;
++ usb2_vbus-supply = <&reg_usb2_vbus>;
++ status = "okay";
++ };
++
++ ehci0: usb@01c14000 {
++ status = "okay";
++ };
++
++ ohci0: usb@01c14400 {
++ status = "okay";
++ };
++
++ ahci: sata@01c18000 {
++ status = "okay";
++ };
++
++ ehci1: usb@01c1c000 {
++ status = "okay";
++ };
++
++ ohci1: usb@01c1c400 {
++ status = "okay";
++ };
++
++ pinctrl@01c20800 {
++ mmc0_cd_pin_bananapi: mmc0_cd_pin@0 {
++ allwinner,pins = "PH10";
++ allwinner,function = "gpio_in";
++ allwinner,drive = <0>;
++ allwinner,pull = <1>;
++ };
++
++ gmac_power_pin_bananapi: gmac_power_pin@0 {
++ allwinner,pins = "PH23";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <0>;
++ allwinner,pull = <0>;
++ };
++
++ led_pins_bananapi: led_pins@0 {
++ allwinner,pins = "PH24";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <0>;
++ allwinner,pull = <0>;
++ };
++
++ ahci_pwr_pin_a: ahci_pwr_pin@0 {
++ allwinner,pins = "PB3";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <0>;
++ allwinner,pull = <0>;
++ };
++
++ };
++
++
++ uart0: serial@01c28000 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&uart0_pins_a>;
++ status = "okay";
++ };
++
++ uart3: serial@01c28c00 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&uart3_pins_b>;
++ status = "okay";
++ };
++
++ uart7: serial@01c29c00 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&uart7_pins_a>;
++ status = "okay";
++ };
++
++ i2c0: i2c@01c2ac00 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&i2c0_pins_a>;
++ status = "okay";
++
++ axp209: pmic@34 {
++ compatible = "x-powers,axp209";
++ reg = <0x34>;
++ interrupt-parent = <&nmi_intc>;
++ interrupts = <0 8>;
++
++ interrupt-controller;
++ #interrupt-cells = <1>;
++ };
++ };
++
++ i2c2: i2c@01c2b400 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&i2c2_pins_a>;
++ status = "okay";
++ };
++
++ gmac: ethernet@01c50000 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&gmac_pins_rgmii_a>;
++ phy = <&phy1>;
++ phy-mode = "rgmii";
++ phy-supply = <&reg_gmac_3v3>;
++ status = "okay";
++
++ phy1: ethernet-phy@1 {
++ reg = <1>;
++ };
++ };
++ };
++
++ leds {
++ compatible = "gpio-leds";
++ pinctrl-names = "default";
++ pinctrl-0 = <&led_pins_bananapi>;
++
++ green {
++ label = "bananapi:green:usr";
++ gpios = <&pio 7 24 0>;
++ };
++ };
++
++ reg_usb1_vbus: usb1-vbus {
++ status = "okay";
++ };
++
++ reg_usb2_vbus: usb2-vbus {
++ status = "okay";
++ };
++
++ reg_gmac_3v3: gmac-3v3 {
++ compatible = "regulator-fixed";
++ pinctrl-names = "default";
++ pinctrl-0 = <&gmac_power_pin_bananapi>;
++ regulator-name = "gmac-3v3";
++ regulator-min-microvolt = <3300000>;
++ regulator-max-microvolt = <3300000>;
++ startup-delay-us = <100000>;
++ enable-active-high;
++ gpio = <&pio 7 23 0>;
++ };
++
++ reg_ahci_5v: ahci-5v {
++ compatible = "regulator-fixed";
++ pinctrl-names = "default";
++ pinctrl-0 = <&ahci_pwr_pin_a>;
++ regulator-name = "ahci-5v";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ enable-active-high;
++ gpio = <&pio 1 3 0>;
++ status = "okay";
++ };
++};
+diff -ruN old/configs/Lamobo_R1_defconfig new/configs/Lamobo_R1_defconfig
+--- old/configs/Lamobo_R1_defconfig 1970-01-01 01:00:00.000000000 +0100
++++ new/configs/Lamobo_R1_defconfig 2015-07-31 23:02:06.000000000 +0200
+@@ -0,0 +1,19 @@
++CONFIG_SPL=y
++CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI,SATAPWR=SUNXI_GPB(3)"
++CONFIG_DEFAULT_DEVICE_TREE="sun7i-a20-lamobo-r1"
++CONFIG_GMAC_TX_DELAY=4
++CONFIG_ARM=y
++CONFIG_ARCH_SUNXI=y
++CONFIG_MACH_SUN7I=y
++CONFIG_DRAM_CLK=432
++CONFIG_DRAM_ZQ=127
++CONFIG_DRAM_EMR1=4
++CONFIG_ETH_DESIGNWARE=y
++CONFIG_NETDEVICES=y
++CONFIG_NET=y
++# CONFIG_CMD_IMLS is not set
++# CONFIG_CMD_FLASH is not set
++# CONFIG_CMD_FPGA is not set
++CONFIG_DM_SERIAL=y
++CONFIG_USB=y
++CONFIG_DM_USB=y
diff --git a/package/boot/uboot-sunxi/patches/002-add-linksprite-pcduino.diff b/package/boot/uboot-sunxi/patches/002-add-linksprite-pcduino.diff
deleted file mode 100644
index 904c815372..0000000000
--- a/package/boot/uboot-sunxi/patches/002-add-linksprite-pcduino.diff
+++ /dev/null
@@ -1,71 +0,0 @@
-diff -ruN u-boot-2015.01-rc3.old/board/sunxi/dram_sun4i_408_1024_iow8.c u-boot-2015.01-rc3/board/sunxi/dram_sun4i_408_1024_iow8.c
---- u-boot-2015.01-rc3.old/board/sunxi/dram_sun4i_408_1024_iow8.c 1970-01-01 01:00:00.000000000 +0100
-+++ u-boot-2015.01-rc3/board/sunxi/dram_sun4i_408_1024_iow8.c 2015-01-06 00:05:07.843497430 +0100
-@@ -0,0 +1,31 @@
-+/* this file is generated, don't edit it yourself */
-+
-+#include <common.h>
-+#include <asm/arch/dram.h>
-+
-+static struct dram_para dram_para = {
-+ .clock = 408,
-+ .type = 3,
-+ .rank_num = 1,
-+ .density = 2048,
-+ .io_width = 8,
-+ .bus_width = 32,
-+ .cas = 6,
-+ .zq = 123,
-+ .odt_en = 0,
-+ .size = 1024,
-+ .tpr0 = 0x30926692,
-+ .tpr1 = 0x1090,
-+ .tpr2 = 0x1a0c8,
-+ .tpr3 = 0,
-+ .tpr4 = 0,
-+ .tpr5 = 0,
-+ .emr1 = 0,
-+ .emr2 = 0,
-+ .emr3 = 0,
-+};
-+
-+unsigned long sunxi_dram_init(void)
-+{
-+ return dramc_init(&dram_para);
-+}
-diff -ruN u-boot-2015.01-rc3.old/board/sunxi/Kconfig u-boot-2015.01-rc3/board/sunxi/Kconfig
---- u-boot-2015.01-rc3.old/board/sunxi/Kconfig 2014-12-08 22:35:08.000000000 +0100
-+++ u-boot-2015.01-rc3/board/sunxi/Kconfig 2015-01-06 00:06:04.218573211 +0100
-@@ -99,6 +99,10 @@
- bool "IPPO_Q8H_V5"
- depends on MACH_SUN8I
-
-+config TARGET_PCDUINO
-+ bool "PCDUINO"
-+ depends on MACH_SUN4I
-+
- config TARGET_PCDUINO3
- bool "PCDUINO3"
- depends on MACH_SUN7I
-diff -ruN u-boot-2015.01-rc3.old/board/sunxi/Makefile u-boot-2015.01-rc3/board/sunxi/Makefile
---- u-boot-2015.01-rc3.old/board/sunxi/Makefile 2014-12-08 22:35:08.000000000 +0100
-+++ u-boot-2015.01-rc3/board/sunxi/Makefile 2015-01-06 00:05:43.718909285 +0100
-@@ -31,6 +31,7 @@
- obj-$(CONFIG_TARGET_MELE_M3) += dram_sun7i_384_1024_iow16.o
- obj-$(CONFIG_TARGET_MINI_X) += dram_sun4i_360_512.o
- obj-$(CONFIG_TARGET_MINI_X_1GB) += dram_sun4i_360_1024_iow16.o
-+obj-$(CONFIG_TARGET_PCDUINO) += dram_sun4i_408_1024_iow8.o
- obj-$(CONFIG_TARGET_PCDUINO3) += dram_linksprite_pcduino3.o
- obj-$(CONFIG_TARGET_QT840A) += dram_sun7i_384_512_busw16_iow16.o
- obj-$(CONFIG_TARGET_R7DONGLE) += dram_r7dongle.o
-diff -ruN u-boot-2015.01-rc3.old/configs/Linksprite_pcDuino_defconfig u-boot-2015.01-rc3/configs/Linksprite_pcDuino_defconfig
---- u-boot-2015.01-rc3.old/configs/Linksprite_pcDuino_defconfig 1970-01-01 01:00:00.000000000 +0100
-+++ u-boot-2015.01-rc3/configs/Linksprite_pcDuino_defconfig 2015-01-06 00:04:37.323997769 +0100
-@@ -0,0 +1,7 @@
-+CONFIG_SPL=y
-+CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_EMAC,USB_EHCI"
-+CONFIG_FDTFILE="sun4i-a10-pcduino.dtb"
-++S:CONFIG_ARM=y
-++S:CONFIG_ARCH_SUNXI=y
-++S:CONFIG_MACH_SUN4I=y
-++S:CONFIG_TARGET_PCDUINO=y
diff --git a/package/boot/uboot-sunxi/patches/003-add-lemaker-bananapro.diff b/package/boot/uboot-sunxi/patches/003-add-lemaker-bananapro.diff
deleted file mode 100644
index 23d0ebf8e5..0000000000
--- a/package/boot/uboot-sunxi/patches/003-add-lemaker-bananapro.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ruN u-boot-2015.01-rc3.old/board/sunxi/Makefile u-boot-2015.01-rc3/board/sunxi/Makefile
---- u-boot-2015.01-rc3.old/board/sunxi/Makefile 2015-01-04 13:01:29.000000000 +0100
-+++ u-boot-2015.01-rc3/board/sunxi/Makefile 2015-01-04 18:06:50.304380318 +0100
-@@ -22,6 +22,7 @@
- obj-$(CONFIG_TARGET_AUXTEK_T004) += dram_a10s_olinuxino_m.o
- obj-$(CONFIG_TARGET_BA10_TV_BOX) += dram_sun4i_384_1024_iow8.o
- obj-$(CONFIG_TARGET_BANANAPI) += dram_bananapi.o
-+obj-$(CONFIG_TARGET_BANANAPRO) += dram_bananapi.o
- obj-$(CONFIG_TARGET_CUBIEBOARD) += dram_cubieboard.o
- obj-$(CONFIG_TARGET_CUBIEBOARD2) += dram_cubieboard2.o
- obj-$(CONFIG_TARGET_CUBIETRUCK) += dram_cubietruck.o
-diff -ruN u-boot-2015.01-rc3.old/configs/Bananapro_defconfig u-boot-2015.01-rc3/configs/Bananapro_defconfig
---- u-boot-2015.01-rc3.old/configs/Bananapro_defconfig 1970-01-01 01:00:00.000000000 +0100
-+++ u-boot-2015.01-rc3/configs/Bananapro_defconfig 2015-01-04 18:06:19.784880656 +0100
-@@ -0,0 +1,7 @@
-+CONFIG_SPL=y
-+CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI"
-+CONFIG_FDTFILE="sun7i-a20-bananapro.dtb"
-++S:CONFIG_ARM=y
-++S:CONFIG_ARCH_SUNXI=y
-++S:CONFIG_MACH_SUN7I=y
-++S:CONFIG_TARGET_BANANAPRO=y
diff --git a/package/boot/uboot-sunxi/patches/003-add-olimex-a13-som.diff b/package/boot/uboot-sunxi/patches/003-add-olimex-a13-som.diff
new file mode 100644
index 0000000000..e160b3da10
--- /dev/null
+++ b/package/boot/uboot-sunxi/patches/003-add-olimex-a13-som.diff
@@ -0,0 +1,19 @@
+diff -ruN u-boot-2015.01.old/configs/OLIMEX_A13_SOM_defconfig u-boot-2015.01/configs/OLIMEX_A13_SOM_defconfig
+--- u-boot-2015.01.old/configs/OLIMEX_A13_SOM_defconfig 1970-01-01 01:00:00.000000000 +0100
++++ u-boot-2015.01/configs/OLIMEX_A13_SOM_defconfig 2015-01-18 16:25:11.908986082 +0100
+@@ -0,0 +1,15 @@
++CONFIG_SPL=y
++CONFIG_SYS_EXTRA_OPTIONS="CONS_INDEX=2,NO_AXP,USB_EHCI"
++CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-olinuxino"
++CONFIG_ARM=y
++CONFIG_ARCH_SUNXI=y
++CONFIG_MACH_SUN5I=y
++CONFIG_DRAM_CLK=408
++CONFIG_DRAM_ZQ=123
++CONFIG_DRAM_EMR1=0
++# CONFIG_CMD_IMLS is not set
++# CONFIG_CMD_FLASH is not set
++# CONFIG_CMD_FPGA is not set
++CONFIG_DM_SERIAL=y
++CONFIG_USB=y
++CONFIG_DM_USB=y
diff --git a/package/boot/uboot-sunxi/patches/004-add-olimex-a13-som.diff b/package/boot/uboot-sunxi/patches/004-add-olimex-a13-som.diff
deleted file mode 100644
index 32ab43b6c1..0000000000
--- a/package/boot/uboot-sunxi/patches/004-add-olimex-a13-som.diff
+++ /dev/null
@@ -1,71 +0,0 @@
-diff -ruN u-boot-2015.01.old/board/sunxi/dram_olimex_a13_som.c u-boot-2015.01/board/sunxi/dram_olimex_a13_som.c
---- u-boot-2015.01.old/board/sunxi/dram_olimex_a13_som.c 1970-01-01 01:00:00.000000000 +0100
-+++ u-boot-2015.01/board/sunxi/dram_olimex_a13_som.c 2015-01-18 15:47:48.738831189 +0100
-@@ -0,0 +1,31 @@
-+/* this file is generated, don't edit it yourself */
-+
-+#include <common.h>
-+#include <asm/arch/dram.h>
-+
-+static struct dram_para dram_para = {
-+ .clock = 408,
-+ .type = 3,
-+ .rank_num = 1,
-+ .density = 4096,
-+ .io_width = 16,
-+ .bus_width = 16,
-+ .cas = 9,
-+ .zq = 123,
-+ .odt_en = 0,
-+ .size = 512,
-+ .tpr0 = 0x42d899b7,
-+ .tpr1 = 0xa090,
-+ .tpr2 = 0x22a00,
-+ .tpr3 = 0,
-+ .tpr4 = 0,
-+ .tpr5 = 0,
-+ .emr1 = 0,
-+ .emr2 = 0x10,
-+ .emr3 = 0,
-+};
-+
-+unsigned long sunxi_dram_init(void)
-+{
-+ return dramc_init(&dram_para);
-+}
-diff -ruN u-boot-2015.01.old/board/sunxi/Kconfig u-boot-2015.01/board/sunxi/Kconfig
---- u-boot-2015.01.old/board/sunxi/Kconfig 2015-01-18 12:48:11.743510311 +0100
-+++ u-boot-2015.01/board/sunxi/Kconfig 2015-01-18 15:48:36.594046646 +0100
-@@ -130,6 +130,10 @@
- bool "MINI_X"
- depends on MACH_SUN4I
-
-+config TARGET_OLIMEX_A13_SOM
-+ bool "OLIMEX_A13_SOM"
-+ depends on MACH_SUN5I
-+
- config TARGET_BA10_TV_BOX
- bool "BA10_TV_BOX"
- depends on MACH_SUN4I
-diff -ruN u-boot-2015.01.old/board/sunxi/Makefile u-boot-2015.01/board/sunxi/Makefile
---- u-boot-2015.01.old/board/sunxi/Makefile 2015-01-18 12:48:11.747510246 +0100
-+++ u-boot-2015.01/board/sunxi/Makefile 2015-01-18 15:48:04.894566330 +0100
-@@ -32,6 +32,7 @@
- obj-$(CONFIG_TARGET_MELE_M3) += dram_sun7i_384_1024_iow16.o
- obj-$(CONFIG_TARGET_MINI_X) += dram_sun4i_360_512.o
- obj-$(CONFIG_TARGET_MINI_X_1GB) += dram_sun4i_360_1024_iow16.o
-+obj-$(CONFIG_TARGET_OLIMEX_A13_SOM) += dram_olimex_a13_som.o
- obj-$(CONFIG_TARGET_PCDUINO) += dram_sun4i_408_1024_iow8.o
- obj-$(CONFIG_TARGET_PCDUINO3) += dram_linksprite_pcduino3.o
- obj-$(CONFIG_TARGET_QT840A) += dram_sun7i_384_512_busw16_iow16.o
-diff -ruN u-boot-2015.01.old/configs/OLIMEX_A13_SOM_defconfig u-boot-2015.01/configs/OLIMEX_A13_SOM_defconfig
---- u-boot-2015.01.old/configs/OLIMEX_A13_SOM_defconfig 1970-01-01 01:00:00.000000000 +0100
-+++ u-boot-2015.01/configs/OLIMEX_A13_SOM_defconfig 2015-01-18 16:25:11.908986082 +0100
-@@ -0,0 +1,7 @@
-+CONFIG_SPL=y
-+CONFIG_SYS_EXTRA_OPTIONS="CONS_INDEX=2,NO_AXP,USB_EHCI"
-+CONFIG_FDTFILE="sun5i-a13-olinuxino.dtb"
-++S:CONFIG_ARM=y
-++S:CONFIG_ARCH_SUNXI=y
-++S:CONFIG_MACH_SUN5I=y
-++S:CONFIG_TARGET_OLIMEX_A13_SOM=y
diff --git a/package/boot/uboot-sunxi/patches/005-add-gmac-tx-delay-variant.patch b/package/boot/uboot-sunxi/patches/005-add-gmac-tx-delay-variant.patch
deleted file mode 100644
index a9183677c3..0000000000
--- a/package/boot/uboot-sunxi/patches/005-add-gmac-tx-delay-variant.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: u-boot-2015.01/board/sunxi/gmac.c
-===================================================================
---- u-boot-2015.01.orig/board/sunxi/gmac.c
-+++ u-boot-2015.01/board/sunxi/gmac.c
-@@ -34,7 +34,7 @@ int sunxi_gmac_initialize(bd_t *bis)
- * need to set bits 10-12 GTXDC "GMAC Transmit Clock Delay Chain"
- * of the GMAC clk register to 3.
- */
--#ifdef CONFIG_TARGET_BANANAPI
-+#ifdef CONFIG_SUNXI_GMAC_TX_DELAY_3
- setbits_le32(&ccm->gmac_clk_cfg, 0x3 << 10);
- #endif
-
-Index: u-boot-2015.01/configs/Bananapi_defconfig
-===================================================================
---- u-boot-2015.01.orig/configs/Bananapi_defconfig
-+++ u-boot-2015.01/configs/Bananapi_defconfig
-@@ -1,5 +1,5 @@
- CONFIG_SPL=y
--CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI"
-+CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,SUNXI_GMAC_TX_DELAY_3,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI"
- CONFIG_FDTFILE="sun7i-a20-bananapi.dtb"
- +S:CONFIG_ARM=y
- +S:CONFIG_ARCH_SUNXI=y
diff --git a/package/boot/uboot-sunxi/patches/006-add-lamobo-r1.patch b/package/boot/uboot-sunxi/patches/006-add-lamobo-r1.patch
deleted file mode 100644
index caa04cbd7e..0000000000
--- a/package/boot/uboot-sunxi/patches/006-add-lamobo-r1.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: u-boot-2015.01/board/sunxi/Makefile
-===================================================================
---- u-boot-2015.01.orig/board/sunxi/Makefile
-+++ u-boot-2015.01/board/sunxi/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_TARGET_AUXTEK_T004) += dram
- obj-$(CONFIG_TARGET_BA10_TV_BOX) += dram_sun4i_384_1024_iow8.o
- obj-$(CONFIG_TARGET_BANANAPI) += dram_bananapi.o
- obj-$(CONFIG_TARGET_BANANAPRO) += dram_bananapi.o
-+obj-$(CONFIG_TARGET_LAMOBO_R1) += dram_bananapi.o
- obj-$(CONFIG_TARGET_CUBIEBOARD) += dram_cubieboard.o
- obj-$(CONFIG_TARGET_CUBIEBOARD2) += dram_cubieboard2.o
- obj-$(CONFIG_TARGET_CUBIETRUCK) += dram_cubietruck.o
-Index: u-boot-2015.01/configs/Lamobo_R1_defconfig
-===================================================================
---- /dev/null
-+++ u-boot-2015.01/configs/Lamobo_R1_defconfig
-@@ -0,0 +1,7 @@
-+CONFIG_SPL=y
-+CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,SUNXI_GMAC_TX_DELAY_3,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI"
-+CONFIG_FDTFILE="sun7i-a20-lamobo-r1.dtb"
-++S:CONFIG_ARM=y
-++S:CONFIG_ARCH_SUNXI=y
-++S:CONFIG_MACH_SUN7I=y
-++S:CONFIG_TARGET_LAMOBO_R1=y