aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-09-27 17:33:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-09-27 17:33:45 +0000
commitb021a87716ad252631516f4290677d69e0e02e93 (patch)
tree18dcf00611f8c6ed09e17d7965e9b88578e2be28
parent6064080971ebc81ea1e92d12cc2e5619997757b7 (diff)
downloadmaster-187ad058-b021a87716ad252631516f4290677d69e0e02e93.tar.gz
master-187ad058-b021a87716ad252631516f4290677d69e0e02e93.tar.bz2
master-187ad058-b021a87716ad252631516f4290677d69e0e02e93.zip
fix ppp compile on osx
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4869 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/ppp/Makefile9
-rw-r--r--package/ppp/patches/010-use_target_for_configure.patch20
2 files changed, 29 insertions, 0 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 680076857e..b5a317bd03 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -23,6 +23,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_BUILDDEP:=libpcap linux-atm
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
define Package/ppp/Default
SECTION:=net
@@ -91,6 +92,14 @@ define Package/pppstats
This package contains an utility to report PPP statistics.
endef
+define Build/Configure
+$(call Build/Configure/Default,, \
+ UNAME_S="Linux" \
+ UNAME_R="$(LINUX_VERSION)" \
+ UNAME_M="$(ARCH)" \
+)
+endef
+
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)/usr
diff --git a/package/ppp/patches/010-use_target_for_configure.patch b/package/ppp/patches/010-use_target_for_configure.patch
new file mode 100644
index 0000000000..56439a6122
--- /dev/null
+++ b/package/ppp/patches/010-use_target_for_configure.patch
@@ -0,0 +1,20 @@
+
+ Use values exported from $(TOPDIR)/rules.mk for determining
+ the target system instead of the host configuration
+
+--- ppp-2.4.3/configure.orig Sat Nov 6 11:36:32 2004
++++ ppp-2.4.3/configure Sun Jun 18 23:40:46 2006
+@@ -8,9 +8,9 @@ SYSCONF=/etc
+ # if [ -d /NextApps ]; then
+ # system="NeXTStep"
+ # else
+- system=`uname -s`
+- release=`uname -r`
+- arch=`uname -m`
++ system=${UNAME_S:-`uname -s`}
++ release=${UNAME_R:-`uname -r`}
++ arch=${UNAME_M:-`uname -m`}
+ # fi
+ state="unknown"
+
+