aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:03 +0000
commitadc4005450dc7fa0ec8ef2940c776e68dfbeb851 (patch)
tree4abdfb8b0f3bb05055bc4ad7f2e9b4f879b0e4c2
parentb71f5661d719adf9f4d8e0986fb2e0c5b19fe5af (diff)
downloadmaster-187ad058-adc4005450dc7fa0ec8ef2940c776e68dfbeb851.tar.gz
master-187ad058-adc4005450dc7fa0ec8ef2940c776e68dfbeb851.tar.bz2
master-187ad058-adc4005450dc7fa0ec8ef2940c776e68dfbeb851.zip
build: remove check for nonexistant CONFIG_TAR_VERBOSITY variable and move TAR_OPTIONS to unpack.mk
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39979 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/unpack.mk2
-rw-r--r--rules.mk6
2 files changed, 2 insertions, 6 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 2d35863095..2b33c4cd8e 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -11,6 +11,8 @@ ifneq ($(HOST_OS),Linux)
else
HOST_TAR:=$(TAR)
endif
+
+TAR_OPTIONS:=-xf -
TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
diff --git a/rules.mk b/rules.mk
index 5d63227339..0769a09278 100644
--- a/rules.mk
+++ b/rules.mk
@@ -272,12 +272,6 @@ else
DISABLE_IPV6:=--disable-ipv6
endif
-ifeq ($(CONFIG_TAR_VERBOSITY),y)
- TAR_OPTIONS:=-xvf -
-else
- TAR_OPTIONS:=-xf -
-endif
-
ifeq ($(CONFIG_BUILD_LOG),y)
BUILD_LOG:=1
endif