aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-18 20:25:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-18 20:25:13 +0000
commita729caa226dda3bac852867a09a679313ecc0659 (patch)
tree7afd120a575fdbce3ab3419a7d97f5ad1b45e236
parent43d2eb64ccb3a223ba2244faee1280aaa6f68d11 (diff)
downloadmaster-187ad058-a729caa226dda3bac852867a09a679313ecc0659.tar.gz
master-187ad058-a729caa226dda3bac852867a09a679313ecc0659.tar.bz2
master-187ad058-a729caa226dda3bac852867a09a679313ecc0659.zip
ar71xx: use custom LZMA dictionary size for WNDR3700 images
Based on a patch by Hannu Nyman. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34248 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 48893e6aac..dbda865ec6 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -69,13 +69,13 @@ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
endif
define CompressLzma
- $(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(2)
+ $(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(3) $(2)
endef
define PatchKernelLzma
cp $(KDIR)/vmlinux $(KDIR_TMP)/vmlinux-$(1)
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR_TMP)/vmlinux-$(1) "$(strip $(2))"
- $(call CompressLzma,$(KDIR_TMP)/vmlinux-$(1),$(KDIR_TMP)/vmlinux-$(1).bin.lzma)
+ $(call CompressLzma,$(KDIR_TMP)/vmlinux-$(1),$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(3))
endef
define PatchKernelGzip
@@ -91,7 +91,7 @@ define MkuImage
endef
define MkuImageLzma
- $(call PatchKernelLzma,$(1),$(2))
+ $(call PatchKernelLzma,$(1),$(2),$(3))
$(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(KDIR_TMP)/vmlinux-$(1).uImage)
endef
@@ -579,7 +579,7 @@ define Image/Build/CyberTAN
endef
define Image/Build/Netgear/Build_uImage
- $(call MkuImageLzma,$(1),$(2) $(3))
+ $(call MkuImageLzma,$(1),$(2) $(3),-d20)
-rm -rf $(KDIR)/$(1)
mkdir -p $(KDIR)/$(1)/image
$(STAGING_DIR_HOST)/bin/wndr3700 \