aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-01-06 02:12:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-01-06 02:12:40 +0000
commita6e0c56eb13795a95282cae71945256e0e8607b9 (patch)
treec25584d03b8ca6197fa48de745649da343851d84
parent7299761c585d1b59624158b58f620b2bd1de1ccd (diff)
downloadmaster-187ad058-a6e0c56eb13795a95282cae71945256e0e8607b9.tar.gz
master-187ad058-a6e0c56eb13795a95282cae71945256e0e8607b9.tar.bz2
master-187ad058-a6e0c56eb13795a95282cae71945256e0e8607b9.zip
fix potential build errors when changing the qc-usb package selection
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10124 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/qc-usb/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/package/qc-usb/Makefile b/package/qc-usb/Makefile
index ff41469b32..47afc8c28b 100644
--- a/package/qc-usb/Makefile
+++ b/package/qc-usb/Makefile
@@ -58,8 +58,7 @@ ifeq ($(KERNEL),2.4)
endif
endif
-ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
- define Build/Compile/kmod
+define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LINUX_DIR="$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \
@@ -68,11 +67,6 @@ ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
LD="$(TARGET_CC) -nodefaultlibs -nostartfiles" \
USER_OPT="$(KERNEL_C_OPTS)" \
quickcam.$(LINUX_KMOD_SUFFIX)
- endef
-endif
-
-define Build/Compile
- $(call Build/Compile/kmod)
$(MAKE) -C $(PKG_BUILD_DIR) \
CFLAGS="$(TARGET_CFLAGS)" \
qcset