aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-12 08:31:17 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-12 08:31:17 +0000
commita6a72a79b71473f876b066444ef36279c58f885f (patch)
tree86254e417370c9f96a6227d0b1354f7180472729
parentca85f7bcbbcb4eb61a4c80230b722fb08904b607 (diff)
downloadmaster-187ad058-a6a72a79b71473f876b066444ef36279c58f885f.tar.gz
master-187ad058-a6a72a79b71473f876b066444ef36279c58f885f.tar.bz2
master-187ad058-a6a72a79b71473f876b066444ef36279c58f885f.zip
linux/netsupport: Add support for MPLS protocol
This adds support for MPLS protocol including usage of lightweight tunnels. Kernel size of vmlinuz.bin grows by ~8k. Signed-off-by: André Valentin <avalentin@marcant.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48710 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/linux/modules/netsupport.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 77bd67a7c3..8a923ed66e 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1001,3 +1001,25 @@ define KernelPackage/rxrpc/description
endef
$(eval $(call KernelPackage,rxrpc))
+
+define KernelPackage/mpls
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=MPLS support
+ KCONFIG:= \
+ CONFIG_MPLS=y \
+ CONFIG_LWTUNNEL=y \
+ CONFIG_NET_MPLS_GSO=m \
+ CONFIG_MPLS_ROUTING=m \
+ CONFIG_MPLS_IPTUNNEL=m
+ FILES:= \
+ $(LINUX_DIR)/net/mpls/mpls_gso.ko \
+ $(LINUX_DIR)/net/mpls/mpls_iptunnel.ko \
+ $(LINUX_DIR)/net/mpls/mpls_router.ko
+ AUTOLOAD:=$(call AutoLoad,30,mpls_router mpls_iptunnel mpls_gso)
+endef
+
+define KernelPackage/mpls/description
+ Kernel support for MPLS
+endef
+
+$(eval $(call KernelPackage,mpls))