aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-02 16:24:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-02 16:24:15 +0000
commita4c9feaf413961a0507ae17f52fb0c30e00df278 (patch)
tree70ce5e9977edc3ae7b2df79e4f0e1dfd60643480
parent3cee58ddf959d805ba55056df447427b36ce03dc (diff)
downloadmaster-187ad058-a4c9feaf413961a0507ae17f52fb0c30e00df278.tar.gz
master-187ad058-a4c9feaf413961a0507ae17f52fb0c30e00df278.tar.bz2
master-187ad058-a4c9feaf413961a0507ae17f52fb0c30e00df278.zip
libnl: Install include files into libnl3
Install header files into same location as pkgconfig/libnl-3.0.pc says: Cflags: -I${includedir}/libnl3 Signed-off-by: Bruno Randolf <br1@einfach.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47102 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/libs/libnl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/libnl/Makefile b/package/libs/libnl/Makefile
index 857bbe272c..241e9a76ed 100644
--- a/package/libs/libnl/Makefile
+++ b/package/libs/libnl/Makefile
@@ -85,8 +85,8 @@ define Build/Compile
endef
define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include/libnl $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl/
+ $(INSTALL_DIR) $(1)/usr/include/libnl3 $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl3/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig