aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
commita3d6680bc3b35f63bf85c8d2970dac3c009280b5 (patch)
treec10c5678bd8fcc35f17e54e9d3e9d93b77833c79
parent814aa23f35dc7479bd4e2e1f21ba933779fcc9e3 (diff)
downloadmaster-187ad058-a3d6680bc3b35f63bf85c8d2970dac3c009280b5.tar.gz
master-187ad058-a3d6680bc3b35f63bf85c8d2970dac3c009280b5.tar.bz2
master-187ad058-a3d6680bc3b35f63bf85c8d2970dac3c009280b5.zip
avoid rdep in the top level make process (subdir.mk) - it leaks too much memory and increases the startup time for regular make commands. timestamp.pl is more lightweight here
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8533 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/subdir.mk10
-rwxr-xr-xscripts/timestamp.pl7
2 files changed, 9 insertions, 8 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 217d6bc376..0a3eff307e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -37,13 +37,9 @@ endef
# Parameters: <subdir> <name> <target>
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
- $(if $(__rdep_$(1)),,
- $(call rdep,$(1),$$($(1)/stamp-$(3)),)
- __rdep_$(1):=1
- )
-
- $$($(1)/stamp-$(3)):
- @+$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+ $$($(1)/stamp-$(3)): $(TMP_DIR)/.build
+ @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) || \
+ $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))
diff --git a/scripts/timestamp.pl b/scripts/timestamp.pl
index a4c5cae015..89ec4e70c3 100755
--- a/scripts/timestamp.pl
+++ b/scripts/timestamp.pl
@@ -39,6 +39,9 @@ while (@ARGV > 0) {
$options{"findopts"} .= " -and -not -path \\*".$str."\\*"
} elsif ($path =~ /^-f/) {
$options{"findopts"} .= " -follow";
+ } elsif ($path =~ /^-n/) {
+ my $arg = $ARGV[0];
+ $options{$path} = $arg;
} elsif ($path =~ /^-/) {
$options{$path} = 1;
} else {
@@ -54,7 +57,9 @@ while (@ARGV > 0) {
}
}
-if ($options{"-p"}) {
+if ($options{"-n"}) {
+ exit ($n eq $options{"-n"} ? 0 : 1);
+} elsif ($options{"-p"}) {
print "$n\n";
} elsif ($options{"-t"}) {
print "$ts\n";