aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-29 11:35:10 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:16:35 +0200
commit98a9b0d65faa0e5b68afec765e88823b4a671e2e (patch)
treeb6d93e87d4a9ea412758aa4c47ab5efea0da90f4
parent1be76263497c4ef5d9f06c2376fa681d6df8d141 (diff)
downloadmaster-187ad058-98a9b0d65faa0e5b68afec765e88823b4a671e2e.tar.gz
master-187ad058-98a9b0d65faa0e5b68afec765e88823b4a671e2e.tar.bz2
master-187ad058-98a9b0d65faa0e5b68afec765e88823b4a671e2e.zip
iproute2: Add package for nstat utility
Add support for the command line utility nstat displaying network statistics Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49271 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/utils/iproute2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index cb9730e683..a7686cb82c 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -60,6 +60,11 @@ $(call Package/iproute2/Default)
TITLE:=Socket statistics utility
endef
+define Package/nstat
+$(call Package/iproute2/Default)
+ TITLE:=Network statistics utility
+endef
+
ifeq ($(BUILD_VARIANT),tiny)
IP_CONFIG_TINY:=y
endif
@@ -128,9 +133,15 @@ define Package/ss/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/ss $(1)/usr/sbin/
endef
+define Package/nstat/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/nstat $(1)/usr/sbin/
+endef
+
$(eval $(call BuildPackage,ip))
$(eval $(call BuildPackage,ip-full))
$(eval $(call BuildPackage,tc))
$(eval $(call BuildPackage,genl))
$(eval $(call BuildPackage,ip-bridge))
$(eval $(call BuildPackage,ss))
+$(eval $(call BuildPackage,nstat))