aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-01 20:31:23 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-01 20:31:23 +0000
commit9831eb0223a97fa0a4eb2de2add24441232f2436 (patch)
treecdcd943d9582cfbcbdd70a692f91e6d8d3a53140
parent9cf168c425e2bcd3b79c6ea08df314dda8b8baf5 (diff)
downloadmaster-187ad058-9831eb0223a97fa0a4eb2de2add24441232f2436.tar.gz
master-187ad058-9831eb0223a97fa0a4eb2de2add24441232f2436.tar.bz2
master-187ad058-9831eb0223a97fa0a4eb2de2add24441232f2436.zip
use the openwrt lzma options for now
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16281 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/998-openwrt_lzma_options.patch8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/998-openwrt_lzma_options.patch b/target/linux/generic-2.6/patches-2.6.30/998-openwrt_lzma_options.patch
new file mode 100644
index 0000000000..8e05052ea4
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/998-openwrt_lzma_options.patch
@@ -0,0 +1,8 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -204,4 +204,4 @@ cmd_bzip2 = (bzip2 -9 < $< && $(size_app
+ # ---------------------------------------------------------------------------
+
+ quiet_cmd_lzma = LZMA $@
+-cmd_lzma = (lzma -9 -c $< && $(size_append) $<) >$@ || (rm -f $@ ; false)
++cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2