aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-16 11:51:54 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-16 11:51:54 +0000
commit88ea80c8f3253f3e8c9c1cc6d22a6e9503d14378 (patch)
treec65cd2c9863b9fbd9cab0b16ef10f4691f34b4db
parentba25eac5190d5d268859f84f8d9d21fc8889cf65 (diff)
downloadmaster-187ad058-88ea80c8f3253f3e8c9c1cc6d22a6e9503d14378.tar.gz
master-187ad058-88ea80c8f3253f3e8c9c1cc6d22a6e9503d14378.tar.bz2
master-187ad058-88ea80c8f3253f3e8c9c1cc6d22a6e9503d14378.zip
buildroot: make it easier to build all kmods
Split out kmods from ALL to make it easier to create local builds that are compatible kmod-wise with releases. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44830 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--config/Config-build.in6
-rw-r--r--include/version.mk2
-rwxr-xr-xscripts/metadata.pl6
3 files changed, 11 insertions, 3 deletions
diff --git a/config/Config-build.in b/config/Config-build.in
index 213609b8b2..582724eff1 100644
--- a/config/Config-build.in
+++ b/config/Config-build.in
@@ -6,8 +6,12 @@
menu "Global build settings"
+ config ALL_KMODS
+ bool "Select all kernel module packages by default"
+ default ALL
+
config ALL
- bool "Select all packages by default"
+ bool "Select all userspace packages by default"
default n
comment "General build options"
diff --git a/include/version.mk b/include/version.mk
index 5cfeae235c..69141ff696 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -53,7 +53,7 @@ $(lastword $(subst :, ,$(1)))
endef
VERSION_TAINT_SPECS := \
- -ALL:no-all \
+ -ALL_KMODS:no-all \
-IPV6:no-ipv6 \
+USE_GLIBC:glibc \
+USE_MKLIBS:mklibs \
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index bfb9ab50e2..92923ea07a 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -545,7 +545,11 @@ sub print_package_config_category($) {
print "\t\t".($pkg->{tristate} ? 'tristate' : 'bool')." $title\n";
print "\t\tdefault y if DEFAULT_".$pkg->{name}."\n";
unless ($pkg->{hidden}) {
- $pkg->{default} ||= "m if ALL";
+ if ($pkg->{name} =~ /^kmod-/) {
+ $pkg->{default} ||= "m if ALL_KMODS";
+ } else {
+ $pkg->{default} ||= "m if ALL";
+ }
}
if ($pkg->{default}) {
foreach my $default (split /\s*,\s*/, $pkg->{default}) {