aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-12 13:28:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-12 13:28:19 +0000
commit80536ac2a5f5c02cdd94430ccc2f09087006c58b (patch)
tree934e3fbc3ae30a37ce74f42eaa711ee4bd200647
parent4f7184970b52625053c5bc415dd8da757f14649d (diff)
downloadmaster-187ad058-80536ac2a5f5c02cdd94430ccc2f09087006c58b.tar.gz
master-187ad058-80536ac2a5f5c02cdd94430ccc2f09087006c58b.tar.bz2
master-187ad058-80536ac2a5f5c02cdd94430ccc2f09087006c58b.zip
avr32: create network config dynamically
The default network configuration from base-files is not correct for the NGW100 board. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35979 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/avr32/base-files.mk5
-rwxr-xr-xtarget/linux/avr32/base-files/etc/uci-defaults/02_network17
2 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/avr32/base-files.mk b/target/linux/avr32/base-files.mk
new file mode 100644
index 0000000000..d6682bd388
--- /dev/null
+++ b/target/linux/avr32/base-files.mk
@@ -0,0 +1,5 @@
+define Package/base-files/install-target
+ rm -f $(1)/etc/config/network
+endef
+
+
diff --git a/target/linux/avr32/base-files/etc/uci-defaults/02_network b/target/linux/avr32/base-files/etc/uci-defaults/02_network
new file mode 100755
index 0000000000..3676146eb5
--- /dev/null
+++ b/target/linux/avr32/base-files/etc/uci-defaults/02_network
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+
+[ -e /etc/config/network ] && exit 0
+
+touch /etc/config/network
+
+. /lib/functions/uci-defaults.sh
+
+ucidef_set_interface_loopback
+ucidef_set_interfaces_lan_wan "eth1" "eth0"
+
+uci commit network
+
+exit 0