aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-12 16:17:13 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-12 16:17:13 +0000
commit7d6e649d46199d1f51a09ad04d420725d4d06ef6 (patch)
tree1bd7e9a45feca19d7c920ca20e2889637d8dd5e2
parentbd3fcf0ac5adb12d7d41855916008aa3606e623f (diff)
downloadmaster-187ad058-7d6e649d46199d1f51a09ad04d420725d4d06ef6.tar.gz
master-187ad058-7d6e649d46199d1f51a09ad04d420725d4d06ef6.tar.bz2
master-187ad058-7d6e649d46199d1f51a09ad04d420725d4d06ef6.zip
oxnas: build S-ATA driver as a module
From: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43665 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/linux/modules/block.mk16
-rw-r--r--target/linux/oxnas/Makefile5
-rw-r--r--target/linux/oxnas/config-3.142
-rw-r--r--target/linux/oxnas/config-3.182
4 files changed, 19 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 8a84aa4e22..20588ac276 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -116,6 +116,22 @@ endef
$(eval $(call KernelPackage,ata-nvidia-sata))
+define KernelPackage/ata-oxnas-sata
+ TITLE:=oxnas Serial ATA support
+ KCONFIG:=CONFIG_SATA_OXNAS
+ DEPENDS:=@TARGET_oxnas
+ FILES:=$(LINUX_DIR)/drivers/ata/sata_oxnas.ko
+ AUTOLOAD:=$(call AutoLoad,41,sata_oxnas,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-oxnas-sata/description
+ SATA support for OX934 core found in the OX82x/PLX782x SoCs
+endef
+
+$(eval $(call KernelPackage,ata-oxnas-sata))
+
+
define KernelPackage/ata-pdc202xx-old
SUBMENU:=$(BLOCK_MENU)
TITLE:=Older Promise PATA controller support
diff --git a/target/linux/oxnas/Makefile b/target/linux/oxnas/Makefile
index d957fcab5c..e919eefe9c 100644
--- a/target/linux/oxnas/Makefile
+++ b/target/linux/oxnas/Makefile
@@ -20,8 +20,9 @@ KERNEL_PATCHVER:=3.14
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
- kmod-button-hotplug kmod-input-gpio-keys-polled kmod-leds-gpio \
- kmod-i2c-gpio uboot-envtools uboot-oxnas-ox820
+ kmod-ata-core kmod-ata-oxnas-sata kmod-button-hotplug \
+ kmod-input-gpio-keys-polled kmod-leds-gpio kmod-usb2-oxnas \
+ uboot-envtools uboot-oxnas-ox820
KERNELNAME:=zImage dtbs
diff --git a/target/linux/oxnas/config-3.14 b/target/linux/oxnas/config-3.14
index 086f870cea..473a2bf75b 100644
--- a/target/linux/oxnas/config-3.14
+++ b/target/linux/oxnas/config-3.14
@@ -25,7 +25,6 @@ CONFIG_ARM_NR_BANKS=8
CONFIG_ARM_PATCH_PHYS_VIRT=y
CONFIG_ARM_THUMB=y
CONFIG_ARM_UNWIND=y
-CONFIG_ATA=y
CONFIG_AUTO_ZRELADDR=y
# CONFIG_BLK_DEV_INITRD is not set
CONFIG_BLK_DEV_SD=y
@@ -298,7 +297,6 @@ CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
CONFIG_RTC_CLASS=y
# CONFIG_RTC_DRV_CMOS is not set
-CONFIG_SATA_OXNAS=y
CONFIG_SCHED_HRTICK=y
CONFIG_SCSI=y
CONFIG_SERIAL_8250_NR_UARTS=1
diff --git a/target/linux/oxnas/config-3.18 b/target/linux/oxnas/config-3.18
index f66650a2e1..56dce65caf 100644
--- a/target/linux/oxnas/config-3.18
+++ b/target/linux/oxnas/config-3.18
@@ -29,7 +29,6 @@ CONFIG_ARM_L1_CACHE_SHIFT=5
CONFIG_ARM_PATCH_PHYS_VIRT=y
CONFIG_ARM_THUMB=y
CONFIG_ARM_UNWIND=y
-CONFIG_ATA=y
# CONFIG_AUDIT_ARCH_COMPAT_GENERIC is not set
CONFIG_AUTO_ZRELADDR=y
# CONFIG_BLK_DEV_INITRD is not set
@@ -316,7 +315,6 @@ CONFIG_RTC_CLASS=y
# CONFIG_RTC_DRV_CMOS is not set
CONFIG_RWSEM_SPIN_ON_OWNER=y
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
-CONFIG_SATA_OXNAS=y
CONFIG_SCHED_HRTICK=y
CONFIG_SCSI=y
CONFIG_SERIAL_8250_NR_UARTS=1