aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-02-22 11:16:35 +0000
committerJonas Gorski <jogo@openwrt.org>2014-02-22 11:16:35 +0000
commit7c03680aea69104a72283fc5cd5b21c5b4a90775 (patch)
treecc4172b2eaddf469b77ca0c1a80e04184d193242
parenta37a113b8125479462fa357f0fa004fcf45de1de (diff)
downloadmaster-187ad058-7c03680aea69104a72283fc5cd5b21c5b4a90775.tar.gz
master-187ad058-7c03680aea69104a72283fc5cd5b21c5b4a90775.tar.bz2
master-187ad058-7c03680aea69104a72283fc5cd5b21c5b4a90775.zip
brcm63xx: Add profile and build image for Sagemcom F@ST2704V2 ADSL router
This adds profile and build image for Sagemcom F@st2704, using b43 driver. For WiFi to work properly BCMA fallback SPROM support patch must be applied (http://git.io/z1Ki8A). Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/4212/ Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39673 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk16
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile3
2 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk b/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk
new file mode 100644
index 0000000000..ebe1755f09
--- /dev/null
+++ b/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Sagemcom-2704V2
+ NAME:=Sagemcom F@ST 2704 V2
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/Sagemcom-2704V2/Description
+ Package set optimized for Sagemcom F@ST 2704 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,Sagemcom-2704V2))
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index dc11c33705..e0bcb07d61 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -255,6 +255,9 @@ define Image/Build
# Sagem F@ST2604
$(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604-cfe)
$(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604,OpenWRT-$(REVISION))
+ # Sagem F@ST2704V2
+ $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2-cfe)
+ $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2,OpenWRT-$(REVISION))
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
# Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0