aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-20 23:59:43 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-20 23:59:43 +0200
commit7b8ae82273fbfbdb9806776825efadf296253bef (patch)
treea682e9c68bd2b3b4bb04fb11d382f9dc192c32ee
parent2b2849c7657c5bdc2ec1f7a25511d94f2f1869ea (diff)
downloadmaster-187ad058-7b8ae82273fbfbdb9806776825efadf296253bef.tar.gz
master-187ad058-7b8ae82273fbfbdb9806776825efadf296253bef.tar.bz2
master-187ad058-7b8ae82273fbfbdb9806776825efadf296253bef.zip
bcm53xx: simplify image building code
Use append-ubi template for ubinize, remove mkfs override Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--target/linux/bcm53xx/image/Makefile29
-rw-r--r--target/linux/bcm53xx/image/ubinize.cfg24
2 files changed, 15 insertions, 38 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index ef1b68f135..012d52fa0c 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -30,16 +30,13 @@ define Build/lzma-d16
@mv $@.new $@
endef
-define Build/mkfs/squashfs
- ( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
-endef
-
define Build/trx-serial
$(STAGING_DIR_HOST)/bin/trx \
- -o $@ \
+ -o $@.new \
-m 33554432 \
-f $(word 1,$^) -a 1024 \
- -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
+ -f $@ -a 0x10000 -A $(KDIR)/fs_mark
+ mv $@.new $@
endef
define Build/trx-nand
@@ -48,11 +45,12 @@ define Build/trx-nand
# root: UBI with one extra block containing UBI mark to trigger erasing
# rest of partition
$(STAGING_DIR_HOST)/bin/trx \
- -o $@ \
+ -o $@.new \
-m 33554432 \
-f $(word 1,$^) -a 0x20000 -b 0x400000 \
- -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
+ -f $@ \
-A $(KDIR)/ubi_mark -a 0x20000
+ mv $@.new $@
endef
define Build/asus-trx
@@ -69,7 +67,7 @@ define Build/seama-nand
-m "type=firmware" \
-f $(word 1,$^) \
-b 0x400000 \
- -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
+ -f $@ \
-f $(KDIR)/ubi_mark
# Seama container
$(STAGING_DIR_HOST)/bin/seama \
@@ -90,12 +88,15 @@ define Device/Default
KERNEL_NAME := zImage
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
IMAGES := trx
- IMAGE/trx := trx-nand
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ UBINIZE_OPTS :=
+ IMAGE/trx := append-ubi | trx-nand
endef
define Device/asus
IMAGES := trx
- IMAGE/trx := trx-nand | asus-trx
+ IMAGE/trx := append-ubi | trx-nand | asus-trx
endef
define AsusDevice
@@ -112,7 +113,7 @@ endef
define Device/dlink
IMAGES := bin
- IMAGE/bin := seama-nand
+ IMAGE/bin := append-ubi | seama-nand
endef
define DLinkDevice
@@ -125,7 +126,7 @@ endef
define Device/netgear
IMAGES := chk
- IMAGE/chk := trx-nand | netgear-chk
+ IMAGE/chk := append-ubi | trx-nand | netgear-chk
NETGEAR_REGION := 1
endef
@@ -154,7 +155,7 @@ endef
define Device/smartrg-sr400ac
IMAGES := trx
- IMAGE/trx := trx-serial
+ IMAGE/trx := append-rootfs | trx-serial
endef
TARGET_DEVICES += \
diff --git a/target/linux/bcm53xx/image/ubinize.cfg b/target/linux/bcm53xx/image/ubinize.cfg
deleted file mode 100644
index a4f2f09d9e..0000000000
--- a/target/linux/bcm53xx/image/ubinize.cfg
+++ /dev/null
@@ -1,24 +0,0 @@
-[rootfs]
-# Volume mode (other option is static)
-mode=ubi
-# Source image
-image=root.squashfs
-# Volume ID in UBI image
-vol_id=0
-# Allow for dynamic resize
-vol_type=dynamic
-# Volume name
-vol_name=rootfs
-
-[rootfs_data]
-# Volume mode (other option is static)
-mode=ubi
-# Volume ID in UBI image
-vol_id=1
-# Allow for dynamic resize
-vol_type=dynamic
-# Volume name
-vol_name=rootfs_data
-# Autoresize volume at first mount
-vol_flags=autoresize
-vol_size=1MiB