aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-12-11 21:13:08 +0000
committerNicolas Thill <nico@openwrt.org>2005-12-11 21:13:08 +0000
commit7a10b426f1f4fcbbc71902563ffbeee4b69e7bc3 (patch)
tree7db929808a25010fb07f1d213ff4b0773e377a60
parent3b0cd99905ad8d0238d098a9b8cbdd2b24fa572f (diff)
downloadmaster-187ad058-7a10b426f1f4fcbbc71902563ffbeee4b69e7bc3.tar.gz
master-187ad058-7a10b426f1f4fcbbc71902563ffbeee4b69e7bc3.tar.bz2
master-187ad058-7a10b426f1f4fcbbc71902563ffbeee4b69e7bc3.zip
fix 2.4 build error introduced by changeset:2606
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2613 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/package/spca5xx/Makefile1
-rw-r--r--target/linux/package/spca5xx/patches/01-kmod-build.patch2
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/package/spca5xx/Makefile b/target/linux/package/spca5xx/Makefile
index 95a48a9a30..d61a04a80c 100644
--- a/target/linux/package/spca5xx/Makefile
+++ b/target/linux/package/spca5xx/Makefile
@@ -18,6 +18,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
ifeq ($(KERNEL_DIR),)
KERNEL_DIR:=$(LINUX_DIR)
endif
+KERNEL_VERSION=$(shell echo "$(LINUX_VERSION)" | cut -d. -f1,2)
include $(TOPDIR)/package/rules.mk
diff --git a/target/linux/package/spca5xx/patches/01-kmod-build.patch b/target/linux/package/spca5xx/patches/01-kmod-build.patch
index f69caf8b91..eb7dccd32e 100644
--- a/target/linux/package/spca5xx/patches/01-kmod-build.patch
+++ b/target/linux/package/spca5xx/patches/01-kmod-build.patch
@@ -26,7 +26,7 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
-# This makefile will build the spca50x driver module external to the kernel
-# source tree. It makes it easier to swap kernels.
-
-+CFLAGS += $(DEFINES)
++EXTRA_CFLAGS += $(DEFINES)
-KERNEL_VERSION = `uname -r`
+spca5xx-objs := drivers/usb/spca5xx.o drivers/usb/spcadecoder.o