aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-09-10 13:37:31 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-09-10 13:37:31 +0000
commit7565cab10417a8d8bb11b05779dd2bd807082bee (patch)
tree468f04b062087fc32f36735e3b47f46739a5f779
parenta67e369c117fc1ec0c66a0d9ac7c2815c64fa9ce (diff)
downloadmaster-187ad058-7565cab10417a8d8bb11b05779dd2bd807082bee.tar.gz
master-187ad058-7565cab10417a8d8bb11b05779dd2bd807082bee.tar.bz2
master-187ad058-7565cab10417a8d8bb11b05779dd2bd807082bee.zip
kernel: add md5sum for 2.6.31 final, and refresh 2.6.31 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17558 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk3
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/840-unable_to_open_console.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/922-gpiommc.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/999-use_preinit_as_init.patch2
4 files changed, 6 insertions, 3 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 986bb7199b..48b1d00e36 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -25,6 +25,9 @@ endif
ifeq ($(LINUX_VERSION),2.6.30.6)
LINUX_KERNEL_MD5SUM:=3ae3add6838da3c5a53baa87c9e32924
endif
+ifeq ($(LINUX_VERSION),2.6.31)
+ LINUX_KERNEL_MD5SUM:=84c077a37684e4cbfa67b18154390d8a
+endif
# disable the md5sum check for unknown kernel versions
LINUX_KERNEL_MD5SUM?=x
diff --git a/target/linux/generic-2.6/patches-2.6.31/840-unable_to_open_console.patch b/target/linux/generic-2.6/patches-2.6.31/840-unable_to_open_console.patch
index 5c381f7133..d9e443a666 100644
--- a/target/linux/generic-2.6/patches-2.6.31/840-unable_to_open_console.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/840-unable_to_open_console.patch
@@ -1,6 +1,6 @@
--- a/init/main.c
+++ b/init/main.c
-@@ -843,7 +843,7 @@ static noinline int init_post(void)
+@@ -844,7 +844,7 @@ static noinline int init_post(void)
numa_default_policy();
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
diff --git a/target/linux/generic-2.6/patches-2.6.31/922-gpiommc.patch b/target/linux/generic-2.6/patches-2.6.31/922-gpiommc.patch
index d8d0840185..9375823f5d 100644
--- a/target/linux/generic-2.6/patches-2.6.31/922-gpiommc.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/922-gpiommc.patch
@@ -829,7 +829,7 @@
+be done automatically.
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -2261,6 +2261,11 @@ T: git git://git.kernel.org/pub/scm/linu
+@@ -2260,6 +2260,11 @@ T: git git://git.kernel.org/pub/scm/linu
S: Maintained
F: drivers/media/video/gspca/
diff --git a/target/linux/generic-2.6/patches-2.6.31/999-use_preinit_as_init.patch b/target/linux/generic-2.6/patches-2.6.31/999-use_preinit_as_init.patch
index 25b1ab1f6f..5d1f61ff02 100644
--- a/target/linux/generic-2.6/patches-2.6.31/999-use_preinit_as_init.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/999-use_preinit_as_init.patch
@@ -1,6 +1,6 @@
--- a/init/main.c
+++ b/init/main.c
-@@ -867,10 +867,7 @@ static noinline int init_post(void)
+@@ -868,10 +868,7 @@ static noinline int init_post(void)
printk(KERN_WARNING "Failed to execute %s. Attempting "
"defaults...\n", execute_command);
}