aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-12-17 08:27:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-12-17 08:27:38 +0000
commit740a5b967811d19990f785ed4b214dd3b445bd2c (patch)
treec983eeb73c30a2ed549565fde82ddb7c5fe02201
parent9bc9764c57d42577fd086208501eb95c5b3ec55a (diff)
downloadmaster-187ad058-740a5b967811d19990f785ed4b214dd3b445bd2c.tar.gz
master-187ad058-740a5b967811d19990f785ed4b214dd3b445bd2c.tar.bz2
master-187ad058-740a5b967811d19990f785ed4b214dd3b445bd2c.zip
[ar71xx]: Belkin AC 1750 DB (F9K1115v2) support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43734 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/uci-defaults/01_leds4
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/uci-defaults/02_network7
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-3.141
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-f9k1115v2.c189
-rw-r--r--target/linux/ar71xx/generic/profiles/belkin.mk18
-rw-r--r--target/linux/ar71xx/image/Makefile27
-rw-r--r--target/linux/ar71xx/patches-3.14/734-MIPS-ath79-add-belkin-ac1750db.patch39
-rw-r--r--tools/firmware-utils/Makefile1
-rw-r--r--tools/firmware-utils/src/edimax_fw_header.c386
12 files changed, 679 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 63e1ca6c86..06b96a3a87 100755
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -80,6 +80,9 @@ get_status_led() {
el-m150)
status_led="easylink:green:system"
;;
+ f9k1115v2)
+ status_led="belkin:blue:status"
+ ;;
gl-inet)
status_led="gl-connect:green:lan"
;;
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
index 9517b97ed1..296ea57f1f 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
@@ -87,6 +87,10 @@ eap300v2)
ucidef_set_led_wlan "wlan" "WLAN" "engenius:blue:wlan" "phy0tpt"
;;
+f9k1115v2)
+ ucidef_set_led_usbdev "usb2" "USB2" "belkin:green:usb2" "1-1"
+ ;;
+
rb-750)
ucidef_set_led_default "act" "act" "rb750:green:act" "1"
ucidef_set_led_netdev "port1" "port1" "rb750:green:port1" "eth1"
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
index e205fd514c..b4b6cb3b68 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
@@ -98,6 +98,13 @@ tew-673gru)
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 5t"
;;
+f9k1115v2)
+ ucidef_set_interfaces_lan_wan "eth1" "eth0"
+ ucidef_add_switch "switch0" "1" "1"
+ ucidef_add_switch_vlan "switch0" "1" "2 3 4 5 6"
+ ucidef_add_switch_vlan "switch0" "2" "0 1"
+ ;;
+
nbg460n_550n_550nh)
ucidef_set_interfaces_lan_wan "eth0" "eth1"
ucidef_add_switch "switch0" "1" "1"
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 483a8ded87..9b056e9d9a 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -272,6 +272,9 @@ ar71xx_board_detect() {
*"Oolite V1.0")
name="oolite"
;;
+ *"AC1750DB")
+ name="f9k1115v2"
+ ;;
*"AirGateway")
name="airgateway"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 2e5b0dd90a..6dabf4e614 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -181,6 +181,7 @@ platform_check_image() {
ap135-020 | \
ap96 | \
db120 | \
+ f9k1115v2 |\
hornet-ub | \
bxu2000n-2-a1 | \
zcn-1523h-2 | \
diff --git a/target/linux/ar71xx/config-3.14 b/target/linux/ar71xx/config-3.14
index 9ed184b160..6098af6ff7 100644
--- a/target/linux/ar71xx/config-3.14
+++ b/target/linux/ar71xx/config-3.14
@@ -57,6 +57,7 @@ CONFIG_ATH79_MACH_EL_MINI=y
CONFIG_ATH79_MACH_ESR1750=y
CONFIG_ATH79_MACH_ESR900=y
CONFIG_ATH79_MACH_EW_DORIN=y
+CONFIG_ATH79_MACH_F9K1115V2=y
CONFIG_ATH79_MACH_GL_INET=y
CONFIG_ATH79_MACH_GS_OOLITE=y
CONFIG_ATH79_MACH_HIWIFI_HC6361=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-f9k1115v2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-f9k1115v2.c
new file mode 100644
index 0000000000..69d005d795
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-f9k1115v2.c
@@ -0,0 +1,189 @@
+/*
+ * Belkin AC1750DB (F9K1115V2) board support
+ *
+ * Copyright (C) 2014 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2014 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define F9K1115V2_GPIO_LED_USB2 4
+#define F9K1115V2_GPIO_LED_WPS_AMBER 14
+#define F9K1115V2_GPIO_LED_STATUS_AMBER 15
+#define F9K1115V2_GPIO_LED_WPS_BLUE 19
+#define F9K1115V2_GPIO_LED_STATUS_BLUE 20
+
+#define F9K1115V2_GPIO_BTN_WPS 16
+#define F9K1115V2_GPIO_BTN_RESET 17
+
+#define F9K1115V2_GPIO_USB2_POWER 21
+
+#define F9K1115V2_KEYS_POLL_INTERVAL 20 /* msecs */
+#define F9K1115V2_KEYS_DEBOUNCE_INTERVAL (3 * F9K1115V2_KEYS_POLL_INTERVAL)
+
+#define F9K1115V2_WAN_MAC_OFFSET 0
+#define F9K1115V2_LAN_MAC_OFFSET 6
+#define F9K1115V2_WMAC_CALDATA_OFFSET 0x1000
+#define F9K1115V2_PCIE_CALDATA_OFFSET 0x5000
+
+static struct gpio_led f9k1115v2_leds_gpio[] __initdata = {
+ {
+ .name = "belkin:amber:status",
+ .gpio = F9K1115V2_GPIO_LED_STATUS_AMBER,
+ .active_low = 1,
+ },
+ {
+ .name = "belkin:blue:status",
+ .gpio = F9K1115V2_GPIO_LED_STATUS_BLUE,
+ .active_low = 1,
+ },
+ {
+ .name = "belkin:blue:wps",
+ .gpio = F9K1115V2_GPIO_LED_WPS_BLUE,
+ .active_low = 1,
+ },
+ {
+ .name = "belkin:amber:wps",
+ .gpio = F9K1115V2_GPIO_LED_WPS_AMBER,
+ .active_low = 1,
+ },
+ {
+ .name = "belkin:green:usb2",
+ .gpio = F9K1115V2_GPIO_LED_USB2,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button f9k1115v2_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = F9K1115V2_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = F9K1115V2_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+ {
+ .desc = "WPS button",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = F9K1115V2_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = F9K1115V2_GPIO_BTN_WPS,
+ .active_low = 1,
+ },
+};
+
+static struct ar8327_pad_cfg f9k1115v2_ar8327_pad0_cfg = {
+ /* Use the RGMII interface for the GMAC0 of the AR8337 switch */
+ .mode = AR8327_PAD_MAC_RGMII,
+ .txclk_delay_en = true,
+ .rxclk_delay_en = true,
+ .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+ .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+};
+
+static struct ar8327_pad_cfg f9k1115v2_ar8327_pad6_cfg = {
+ /* Use the SGMII interface for the GMAC6 of the AR8337 switch */
+ .mode = AR8327_PAD_MAC_SGMII,
+ .rxclk_delay_en = true,
+ .rxclk_delay_sel = AR8327_CLK_DELAY_SEL0,
+};
+
+static struct ar8327_platform_data f9k1115v2_ar8327_data = {
+ .pad0_cfg = &f9k1115v2_ar8327_pad0_cfg,
+ .pad6_cfg = &f9k1115v2_ar8327_pad6_cfg,
+ .port0_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+ .port6_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+};
+
+static struct mdio_board_info f9k1115v2_mdio0_info[] = {
+ {
+ .bus_id = "ag71xx-mdio.0",
+ .phy_addr = 0,
+ .platform_data = &f9k1115v2_ar8327_data,
+ },
+};
+
+static void __init f9k1115v2_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(f9k1115v2_leds_gpio),
+ f9k1115v2_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, F9K1115V2_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(f9k1115v2_gpio_keys),
+ f9k1115v2_gpio_keys);
+
+ ath79_register_wmac(art + F9K1115V2_WMAC_CALDATA_OFFSET, NULL);
+
+ ath79_register_mdio(0, 0x0);
+ mdiobus_register_board_info(f9k1115v2_mdio0_info,
+ ARRAY_SIZE(f9k1115v2_mdio0_info));
+
+ ath79_setup_qca955x_eth_cfg(QCA955X_ETH_CFG_RGMII_EN);
+
+ ath79_init_mac(ath79_eth0_data.mac_addr,
+ art + F9K1115V2_WAN_MAC_OFFSET, 0);
+
+ ath79_init_mac(ath79_eth1_data.mac_addr,
+ art + F9K1115V2_LAN_MAC_OFFSET, 0);
+
+ ath79_eth0_pll_data.pll_1000 = 0xa6000000;
+ ath79_eth1_pll_data.pll_1000 = 0x03000101;
+
+ /* GMAC0 is connected to the RMGII interface */
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+
+ ath79_register_eth(0);
+
+ /* GMAC1 is connected to the SGMII interface */
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+ ath79_eth1_data.speed = SPEED_1000;
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+
+ ath79_register_eth(1);
+
+ ath79_register_pci();
+
+ ath79_register_usb();
+ gpio_request_one(F9K1115V2_GPIO_USB2_POWER,
+ GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+ "USB2 power");
+}
+
+MIPS_MACHINE(ATH79_MACH_F9K1115V2, "F9K1115V2", "Belkin AC1750DB",
+ f9k1115v2_setup);
diff --git a/target/linux/ar71xx/generic/profiles/belkin.mk b/target/linux/ar71xx/generic/profiles/belkin.mk
new file mode 100644
index 0000000000..c8f6bdec4b
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/belkin.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/F9K1115V2
+ NAME:=Belkin AC1750DB (F9K1115V2)
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb3 kmod-ledtrig-usbdev \
+ kmod-ath10k
+endef
+
+define Profile/F9K1115V2/Description
+ Package set optimized for the Belkin AC1750DB (F9K1115V2) board.
+endef
+
+$(eval $(call Profile,F9K1115V2))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a057f2acf2..18c9637b0c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -286,6 +286,7 @@ esr900_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),
esr1750_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),13248k(rootfs),1024k(manufacture)ro,64k(backup)ro,320k(storage)ro,64k(caldata)ro,14656k@0x40000(firmware)
ew-dorin_mtdlayout_4M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),3712k(firmware),64k(art)
ew-dorin_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)
+f9k1115v2_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),14464k(rootfs),1408k(kernel),64k(nvram)ro,64k(envram)ro,64k(art)ro,15872k@0x50000(firmware)
dlrtdev_mtdlayout=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,6208k(firmware),64k(caldata)ro,640k(certs),960k(unknown)ro,64k@0x7f0000(caldata_copy)
dlrtdev_mtdlayout_fat=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,7168k(firmware),640k(certs),64k(caldata)ro,64k@0x660000(caldata_orig),6208k@0x50000(firmware_orig)
dragino2_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,16000k(firmware),64k(config)ro,64k(art)ro
@@ -508,6 +509,30 @@ Image/Build/AthLzma=$(call Image/Build/Ath,$(1),$(2),$(3),$(4),$(5),$(6),$(7))
Image/Build/AthLzma/initramfs=$(call MkuImageLzma/initramfs,$(2),$(3) $(4))
+Image/Build/Belkin/buildkernel=$(call MkuImageLzma,$(2),$(3) $(4))
+Image/Build/Belkin/initramfs=$(call MkuImageLzma/initramfs,$(2),$(3) $(4))
+
+define Image/Build/Belkin
+ $(eval fwsize=$(call mtdpartsize,firmware,$(4)))
+ $(eval kernsize=$(call mtdpartsize,kernel,$(4)))
+ $(eval rootsize=$(call mtdpartsize,rootfs,$(4)))
+ $(call Sysupgrade/RKuImage,$(1),$(2),$(kernsize),$(rootsize))
+ if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+ edimax_fw_header -m $(5) -v "OpenWrt$(REVISION)" \
+ -n "uImage" \
+ -i $(KDIR_TMP)/vmlinux-$(2).uImage \
+ -o $(KDIR_TMP)/$(2)-uImage; \
+ edimax_fw_header -m $(5) -v "OpenWrt$(REVISION)" \
+ -n "rootfs" \
+ -i $(KDIR)/root.$(1) \
+ -o $(KDIR_TMP)/$(2)-rootfs; \
+ ( \
+ dd if=$(KDIR_TMP)/$(2)-rootfs; \
+ dd if=$(KDIR_TMP)/$(2)-uImage; \
+ ) > "$(call factoryname,$(1),$(2))"; \
+ fi
+endef
+
define Image/Build/EnGenius
$(eval fwsize=$(call mtdpartsize,firmware,$(4)))
$(eval rootsize=$(call mtdpartsize,rootfs,$(4)))
@@ -1148,6 +1173,8 @@ $(eval $(call SingleProfile,AthLzma,64k,PB92,pb92,PB92,ttyS0,115200,$$(pb92_mtdl
$(eval $(call SingleProfile,AthLzma,64k,TUBE2H16M,tube2h-16M,TUBE2H,ttyATH0,115200,$$(alfa_mtdlayout_16M),KRuImage,65536))
$(eval $(call SingleProfile,AthLzma,64k,WLR8100,wlr8100,WLR8100,ttyS0,115200,$$(wlr8100_mtdlayout),KRuImage))
+$(eval $(call SingleProfile,Belkin,64k,F9K1115V2,f9k1115v2,F9K1115V2,ttyS0,115200,$$(f9k1115v2_mtdlayout),BR-6679BAC))
+
$(eval $(call SingleProfile,CameoAP91,64kraw,DIR600A1,dir-600-a1,DIR-600-A1,ttyS0,115200,"AP91-AR7240-RT-090223-00"))
$(eval $(call SingleProfile,CameoAP91,64kraw,DIR601A1,dir-601-a1,DIR-600-A1,ttyS0,115200,"AP91-AR7240-RT-090223-02"))
$(eval $(call SingleProfile,CameoAP91,64kraw,FR54RTR,fr-54rtr,DIR-600-A1,ttyS0,115200,"AP91-AR7240-RT-090223-01"))
diff --git a/target/linux/ar71xx/patches-3.14/734-MIPS-ath79-add-belkin-ac1750db.patch b/target/linux/ar71xx/patches-3.14/734-MIPS-ath79-add-belkin-ac1750db.patch
new file mode 100644
index 0000000000..da7a7d3e6f
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.14/734-MIPS-ath79-add-belkin-ac1750db.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -70,6 +70,7 @@ obj-$(CONFIG_ATH79_MACH_EAP7660D) += mac
+ obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
+ obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach-el-mini.o
+ obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
++obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
+ obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
+ obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
+ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361) += mach-hiwifi-hc6361.o
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -186,6 +186,16 @@ config ATH79_MACH_AW_NR580
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++config ATH79_MACH_F9K1115V2
++ bool "Belkin AC1750DB board support"
++ select SOC_QCA955X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_ESR1750
+ bool "EnGenius ESR1750 board support"
+ select SOC_QCA955X
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -59,6 +59,7 @@ enum ath79_mach_type {
+ ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
+ ATH79_MACH_EL_MINI, /* EasyLink EL-MINI */
+ ATH79_MACH_ESR1750, /* EnGenius ESR1750 */
++ ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
+ ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
+ ATH79_MACH_HIWIFI_HC6361, /* HiWiFi HC6361 */
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 988c6256af..83c51d7d90 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -71,6 +71,7 @@ define Host/Compile
$(call cc,mkheader_gemtek,-lz)
$(call cc,mkrtn56uimg, -lz)
$(call cc,dgn3500sum)
+ $(call cc,edimax_fw_header, -Wall)
endef
define Host/Install
diff --git a/tools/firmware-utils/src/edimax_fw_header.c b/tools/firmware-utils/src/edimax_fw_header.c
new file mode 100644
index 0000000000..ff094da1ad
--- /dev/null
+++ b/tools/firmware-utils/src/edimax_fw_header.c
@@ -0,0 +1,386 @@
+/*
+ * Copyright (C) 2014 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ *
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stdint.h>
+#include <string.h>
+#include <unistd.h> /* for unlink() */
+#include <libgen.h>
+#include <getopt.h> /* for getopt() */
+#include <stdarg.h>
+#include <errno.h>
+#include <sys/stat.h>
+
+#include <arpa/inet.h>
+#include <netinet/in.h>
+
+#define MAX_MAGIC_LEN 16
+#define MAX_MODEL_LEN 32
+#define MAX_VERSION_LEN 14
+#define MAX_MTD_NAME_LEN 16
+
+#define FIELD_SIZEOF(t, f) (sizeof(((t*)0)->f))
+
+struct edimax_header {
+ char magic[MAX_MAGIC_LEN];
+ char model[MAX_MODEL_LEN];
+ unsigned char force;
+ unsigned char header_csum;
+ unsigned char data_csum;
+ uint32_t data_size;
+ uint32_t start_addr;
+ uint32_t end_addr;
+ char fw_version[MAX_VERSION_LEN];
+ unsigned char type;
+ char mtd_name[MAX_MTD_NAME_LEN];
+} __attribute__ ((packed));
+
+/*
+ * Globals
+ */
+static char *ofname;
+static char *ifname;
+static char *progname;
+
+static char *model;
+static char *magic = "eDiMaX";
+static char *fw_version = "";
+static char *mtd_name;
+static int force;
+static uint32_t start_addr;
+static uint32_t end_addr;
+static uint8_t image_type;
+static int data_size;
+
+/*
+ * Message macros
+ */
+#define ERR(fmt, ...) do { \
+ fflush(0); \
+ fprintf(stderr, "[%s] *** error: " fmt "\n", \
+ progname, ## __VA_ARGS__ ); \
+} while (0)
+
+#define ERRS(fmt, ...) do { \
+ int save = errno; \
+ fflush(0); \
+ fprintf(stderr, "[%s] *** error: " fmt " (%s)\n", \
+ progname, ## __VA_ARGS__, strerror(save)); \
+} while (0)
+
+#define DBG(fmt, ...) do { \
+ fprintf(stderr, "[%s] " fmt "\n", progname, ## __VA_ARGS__ ); \
+} while (0)
+
+static void usage(int status)
+{
+ FILE *stream = (status != EXIT_SUCCESS) ? stderr : stdout;
+
+ fprintf(stream, "Usage: %s [OPTIONS...]\n", progname);
+ fprintf(stream,
+"\n"
+"Options:\n"
+" -e <addr> set end addr to <addr>\n"
+" -f set force flag\n"
+" -h show this screen\n"
+" -i <file> read input data from the file <file>\n"
+" -o <file> write output to the file <file>\n"
+" -m <model> set model to <model>\n"
+" -M <magic> set image magic to <magic>\n"
+" -n <name> set MTD device name to <name>\n"
+" -s <addr> set start address to <addr>\n"
+" -t <type> set image type to <type>\n"
+" -v <version> set firmware version to <version>\n"
+ );
+
+ exit(status);
+}
+
+int
+str2u32(char *arg, uint32_t *val)
+{
+ char *err = NULL;
+ uint32_t t;
+
+ errno=0;
+ t = strtoul(arg, &err, 0);
+ if (errno || (err==arg) || ((err != NULL) && *err)) {
+ return -1;
+ }
+
+ *val = t;
+ return 0;
+}
+
+int
+str2u8(char *arg, uint8_t *val)
+{
+ char *err = NULL;
+ uint32_t t;
+
+ errno=0;
+ t = strtoul(arg, &err, 0);
+ if (errno || (err==arg) || ((err != NULL) && *err) || (t >= 0x100)) {
+ return -1;
+ }
+
+ *val = t & 0xFF;
+ return 0;
+}
+
+static int get_file_size(char *name)
+{
+ struct stat st;
+ int res;
+
+ res = stat(name, &st);
+ if (res){
+ ERRS("stat failed on %s", name);
+ return -1;
+ }
+
+ return st.st_size;
+}
+
+static int read_to_buf(char *name, char *buf, int buflen)
+{
+ FILE *f;
+ int ret = EXIT_FAILURE;
+
+ f = fopen(name, "r");
+ if (f == NULL) {
+ ERRS("could not open \"%s\" for reading", name);
+ goto out;
+ }
+
+ errno = 0;
+ fread(buf, buflen, 1, f);
+ if (errno != 0) {
+ ERRS("unable to read from file \"%s\"", name);
+ goto out_close;
+ }
+
+ ret = EXIT_SUCCESS;
+
+out_close:
+ fclose(f);
+out:
+ return ret;
+}
+
+static int check_options(void)
+{
+#define CHKSTR(_name, _msg) \
+ do { \
+ if (_name == NULL) { \
+ ERR("no %s specified", _msg); \
+ return -1; \
+ } \
+ } while (0)
+
+#define CHKSTRLEN(_name, _msg) \
+ do { \
+ int field_len; \
+ CHKSTR(_name, _msg); \
+ field_len = FIELD_SIZEOF(struct edimax_header, _name) - 1; \
+ if (strlen(_name) > field_len) { \
+ ERR("'%s' is too long, max %s length is %d", \
+ _name, _msg, field_len); \
+ return -1; \
+ } \
+ } while (0)
+
+ CHKSTR(ofname, "output file");
+ CHKSTR(ifname, "input file");
+
+ CHKSTRLEN(magic, "magic");
+ CHKSTRLEN(model, "model");
+ CHKSTRLEN(mtd_name, "MTD device name");
+ CHKSTRLEN(fw_version, "firware version");
+
+ data_size = get_file_size(ifname);
+ if (data_size < 0)
+ return -1;
+
+ return 0;
+}
+
+static int write_fw(char *data, int len)
+{
+ FILE *f;
+ int ret = EXIT_FAILURE;
+
+ f = fopen(ofname, "w");
+ if (f == NULL) {
+ ERRS("could not open \"%s\" for writing", ofname);
+ goto out;
+ }
+
+ errno = 0;
+ fwrite(data, len, 1, f);
+ if (errno) {
+ ERRS("unable to write output file");
+ goto out_flush;
+ }
+
+ DBG("firmware file \"%s\" completed", ofname);
+
+ ret = EXIT_SUCCESS;
+
+out_flush:
+ fflush(f);
+ fclose(f);
+ if (ret != EXIT_SUCCESS) {
+ unlink(ofname);
+ }
+out:
+ return ret;
+}
+
+static unsigned char checksum(unsigned char *p, unsigned len)
+{
+ unsigned char csum = 0;
+
+ while (len--)
+ csum += *p++;
+
+ csum ^= 0xb9;
+
+ return csum;
+}
+
+static int build_fw(void)
+{
+ int buflen;
+ char *buf;
+ char *data;
+ struct edimax_header *hdr;
+ int ret = EXIT_FAILURE;
+
+ buflen = sizeof(struct edimax_header) + data_size;
+
+ buf = malloc(buflen);
+ if (!buf) {
+ ERR("no memory for buffer\n");
+ goto out;
+ }
+
+ data = buf + sizeof(struct edimax_header);
+
+ /* read input file */
+ ret = read_to_buf(ifname, data, data_size);
+ if (ret)
+ goto out_free_buf;
+
+ /* fill firmware header */
+ hdr = (struct edimax_header *)buf;
+ memset(hdr, 0, sizeof(struct edimax_header *));
+
+ strncpy(hdr->model, model, sizeof(hdr->model));
+ strncpy(hdr->magic, magic, sizeof(hdr->magic));
+ strncpy(hdr->fw_version, fw_version, sizeof(hdr->fw_version));
+ strncpy(hdr->mtd_name, mtd_name, sizeof(hdr->mtd_name));
+
+ hdr->force = force;
+ hdr->start_addr = htonl(start_addr);
+ hdr->end_addr = htonl(end_addr);
+ hdr->data_size = htonl(data_size);
+ hdr->type = image_type;
+
+ hdr->data_csum = checksum((unsigned char *)data, data_size);
+ hdr->header_csum = checksum((unsigned char *)hdr,
+ sizeof(struct edimax_header));
+
+ ret = write_fw(buf, buflen);
+ if (ret)
+ goto out_free_buf;
+
+ ret = EXIT_SUCCESS;
+
+out_free_buf:
+ free(buf);
+out:
+ return ret;
+}
+
+int main(int argc, char *argv[])
+{
+ int ret = EXIT_FAILURE;
+
+ progname = basename(argv[0]);
+
+ while (1) {
+ int c;
+
+ c = getopt(argc, argv, "e:fhi:o:m:M:n:s:t:v:");
+ if (c == -1)
+ break;
+
+ switch (c) {
+ case 'e':
+ if (str2u32(optarg, &end_addr)) {
+ ERR("%s is invalid '%s'",
+ "end address", optarg);
+ goto out;
+ }
+ break;
+ case 'f':
+ force = 1;
+ break;
+ case 'i':
+ ifname = optarg;
+ break;
+ case 'h':
+ usage(EXIT_SUCCESS);
+ break;
+ case 'o':
+ ofname = optarg;
+ break;
+ case 'm':
+ model = optarg;
+ break;
+ case 'M':
+ magic = optarg;
+ break;
+ case 'n':
+ mtd_name = optarg;
+ break;
+ case 's':
+ if (str2u32(optarg, &start_addr)) {
+ ERR("%s is invalid '%s'",
+ "start address", optarg);
+ goto out;
+ }
+ break;
+ case 't':
+ if (str2u8(optarg, &image_type)) {
+ ERR("%s is invalid '%s'",
+ "image type", optarg);
+ goto out;
+ }
+ break;
+ case 'v':
+ fw_version = optarg;
+ break;
+ default:
+ usage(EXIT_FAILURE);
+ break;
+ }
+ }
+
+ ret = check_options();
+ if (ret)
+ goto out;
+
+ ret = build_fw();
+
+out:
+ return ret;
+}