aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-09-08 07:25:20 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-09-08 07:25:20 +0000
commit738c6e15688d9b50324b1c66455c5e27fe251bd7 (patch)
treeae83e39f76d2dd0b45f64e4bd30deefb3f9ffaa2
parentd4cec654bc5e6baff83b1ea645877ca4db64c441 (diff)
downloadmaster-187ad058-738c6e15688d9b50324b1c66455c5e27fe251bd7.tar.gz
master-187ad058-738c6e15688d9b50324b1c66455c5e27fe251bd7.tar.bz2
master-187ad058-738c6e15688d9b50324b1c66455c5e27fe251bd7.zip
add menuconfig option for enabling debugfs support in the kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17540 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in10
-rw-r--r--include/kernel-defaults.mk1
2 files changed, 11 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 699c689406..e03cf03af3 100644
--- a/Config.in
+++ b/Config.in
@@ -195,6 +195,7 @@ config KERNEL_KALLSYMS
default n
help
This will give you more information in stack traces from kernel oopses
+
config KERNEL_PROFILING
bool "Compile the kernel with profiling enabled"
default n
@@ -202,6 +203,15 @@ config KERNEL_PROFILING
Enable the extended profiling support mechanisms used by profilers such
as OProfile.
+config KERNEL_DEBUG_FS
+ bool "Compile the kernel with Debug Filesystem enabled"
+ depends LINUX_2_6
+ default y
+ help
+ debugfs is a virtual file system that kernel developers use to put
+ debugging files into. Enable this option to be able to read and
+ write to these files.
+
endmenu
menuconfig DEVEL
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 4266157d26..cf3eb31053 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -97,6 +97,7 @@ define Kernel/Configure/Default
$(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
echo "$(if $(CONFIG_KERNEL_PROFILING),CONFIG_PROFILING=y,# CONFIG_PROFILING is not set)" >> $(LINUX_DIR)/.config.target
+ echo "$(if $(CONFIG_KERNEL_DEBUG_FS),CONFIG_DEBUG_FS=y,# CONFIG_DEBUG_FS is not set)" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target