aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-02-07 17:48:33 +0000
committerLuka Perkov <luka@openwrt.org>2015-02-07 17:48:33 +0000
commit6ca16eadc3a526b8eb7be1c57462bd7fc0f463d4 (patch)
treecd731ab99c18242541ab6b4eb84fee8ce182d4a8
parent03bbda68407e6d5a684f04b5a3154fe1cf340c00 (diff)
downloadmaster-187ad058-6ca16eadc3a526b8eb7be1c57462bd7fc0f463d4.tar.gz
master-187ad058-6ca16eadc3a526b8eb7be1c57462bd7fc0f463d4.tar.bz2
master-187ad058-6ca16eadc3a526b8eb7be1c57462bd7fc0f463d4.zip
kernel: update 3.14 to 3.14.32
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44302 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-3.14/432-mtd-bcm47xxpart-detect-T_Meter-partition.patch13
-rw-r--r--target/linux/generic/patches-3.14/902-debloat_proc.patch2
3 files changed, 7 insertions, 12 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 3cfcc8cd0a..cd282888b1 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -5,14 +5,14 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.8 = .13
LINUX_VERSION-3.10 = .58
LINUX_VERSION-3.13 = .7
-LINUX_VERSION-3.14 = .30
+LINUX_VERSION-3.14 = .32
LINUX_VERSION-3.18 = .5
LINUX_VERSION-3.19 = -rc5
LINUX_KERNEL_MD5SUM-3.8.13 = 2af19d06cd47ec459519159cdd10542d
LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
LINUX_KERNEL_MD5SUM-3.13.7 = 370adced5e5c1cb1d0d621c2dae2723f
-LINUX_KERNEL_MD5SUM-3.14.30 = 5926982f20bbef0988fca03b92fe43a5
+LINUX_KERNEL_MD5SUM-3.14.32 = 3178fb8f6f1eafcffdd730fec68754f8
LINUX_KERNEL_MD5SUM-3.18.5 = b655fcbc4597aa4b0cbabcfc72983259
ifdef KERNEL_PATCHVER
diff --git a/target/linux/generic/patches-3.14/432-mtd-bcm47xxpart-detect-T_Meter-partition.patch b/target/linux/generic/patches-3.14/432-mtd-bcm47xxpart-detect-T_Meter-partition.patch
index 3f70225980..1edc99525d 100644
--- a/target/linux/generic/patches-3.14/432-mtd-bcm47xxpart-detect-T_Meter-partition.patch
+++ b/target/linux/generic/patches-3.14/432-mtd-bcm47xxpart-detect-T_Meter-partition.patch
@@ -14,8 +14,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
drivers/mtd/bcm47xxpart.c | 10 ++++++++++
1 file changed, 10 insertions(+)
-diff --git a/drivers/mtd/bcm47xxpart.c b/drivers/mtd/bcm47xxpart.c
-index f14ec0f..40dd0db 100644
--- a/drivers/mtd/bcm47xxpart.c
+++ b/drivers/mtd/bcm47xxpart.c
@@ -39,6 +39,7 @@
@@ -26,10 +24,11 @@ index f14ec0f..40dd0db 100644
#define ML_MAGIC1 0x39685a42
#define ML_MAGIC2 0x26594131
#define TRX_MAGIC 0x30524448
-@@ -177,6 +178,15 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -176,6 +177,15 @@ static int bcm47xxpart_parse(struct mtd_
+ MTD_WRITEABLE);
continue;
}
-
++
+ /* T_Meter */
+ if ((le32_to_cpu(buf[0x000 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
+ (le32_to_cpu(buf[0x030 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
@@ -38,10 +37,6 @@ index f14ec0f..40dd0db 100644
+ MTD_WRITEABLE);
+ continue;
+ }
-+
+
/* TRX */
if (buf[0x000 / 4] == TRX_MAGIC) {
- if (BCM47XXPART_MAX_PARTS - curr_part < 4) {
---
-1.8.4.5
-
diff --git a/target/linux/generic/patches-3.14/902-debloat_proc.patch b/target/linux/generic/patches-3.14/902-debloat_proc.patch
index 9024d6401e..55e21a43ba 100644
--- a/target/linux/generic/patches-3.14/902-debloat_proc.patch
+++ b/target/linux/generic/patches-3.14/902-debloat_proc.patch
@@ -133,7 +133,7 @@
}
--- a/mm/vmstat.c
+++ b/mm/vmstat.c
-@@ -1302,10 +1302,12 @@ static int __init setup_vmstat(void)
+@@ -1303,10 +1303,12 @@ static int __init setup_vmstat(void)
put_online_cpus();
#endif
#ifdef CONFIG_PROC_FS