diff options
author | Felix Fietkau <nbd@openwrt.org> | 2015-06-15 23:05:08 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2015-06-15 23:05:08 +0000 |
commit | 6c5fac761a23f2f6d9e4ca1591896efeaad4fb9f (patch) | |
tree | 5ab8c582c03a15e88311381fb5e5f524421b938d | |
parent | c6917af6b1ffea38d2483d90d161587745000e67 (diff) | |
download | master-187ad058-6c5fac761a23f2f6d9e4ca1591896efeaad4fb9f.tar.gz master-187ad058-6c5fac761a23f2f6d9e4ca1591896efeaad4fb9f.tar.bz2 master-187ad058-6c5fac761a23f2f6d9e4ca1591896efeaad4fb9f.zip |
toolchain: switch to musl by default, except for mips64
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45995 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | rules.mk | 2 | ||||
-rw-r--r-- | toolchain/Config.in | 8 |
2 files changed, 5 insertions, 5 deletions
@@ -89,7 +89,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),) REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX)) GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-openwrt-linux DIR_SUFFIX:=_$(LIBC)-$(LIBCV)$(if $(CONFIG_arm),_eabi) - BIN_DIR:=$(BIN_DIR)$(if $(CONFIG_USE_UCLIBC),,-$(LIBC)) + BIN_DIR:=$(BIN_DIR)$(if $(CONFIG_USE_MUSL),,-$(LIBC)) TARGET_DIR_NAME = target-$(ARCH)$(ARCH_SUFFIX)$(DIR_SUFFIX)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX)) TOOLCHAIN_DIR_NAME = toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)$(DIR_SUFFIX) else diff --git a/toolchain/Config.in b/toolchain/Config.in index 7b365e4c5e..1e9460244d 100644 --- a/toolchain/Config.in +++ b/toolchain/Config.in @@ -211,8 +211,8 @@ comment "C Library" choice prompt "C Library implementation" if TOOLCHAINOPTS - default LIBC_USE_GLIBC if (aarch64 || aarch64_be) - default LIBC_USE_UCLIBC + default LIBC_USE_UCLIBC if mips64 || mips64el + default LIBC_USE_MUSL help Select the C library implementation. @@ -257,13 +257,13 @@ config INSIGHT config USE_GLIBC bool - default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && (aarch64 || aarch64_be || octeon) config USE_UCLIBC + default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && (mips64 || mips64el) bool - default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && !(aarch64 || aarch64_be || octeon) config USE_MUSL + default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && !(mips64 || mips64el) bool config USE_EXTERNAL_LIBC |