aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTydus <tydus@hongo.wide.ad.jp>2016-12-18 13:38:41 +0900
committerTydus <tydus@hongo.wide.ad.jp>2016-12-19 23:44:52 +0900
commit6c2ca35fdf45a69947793ecadcc29e64fa9bdc5f (patch)
tree8f2597290c24dcdea9e5ae638080cdc59903d6bf
parent851a890647205e58363f391664696104a6608464 (diff)
downloadmaster-187ad058-6c2ca35fdf45a69947793ecadcc29e64fa9bdc5f.tar.gz
master-187ad058-6c2ca35fdf45a69947793ecadcc29e64fa9bdc5f.tar.bz2
master-187ad058-6c2ca35fdf45a69947793ecadcc29e64fa9bdc5f.zip
modules: Add kmod-igbvf kernel module for Intel(R) 82576 Virtual Function Ethernet adapters
Intel(R) 82576 is an adapter which supports SR-IOV. Thus the host can assign Virtual Functions (VFs) to different by the PCI-E Passthrough (e.g. VFIO for KVM), to gain different advantages (performance, VF to VF communications, host kernel offload, etc.). The driver of the passthroughed VFs is the igbvf (igb is NOT compatible). This is essential for VM guests, to enable them to utilize this feature. Signed-off-by: Tydus <tydus@hongo.wide.ad.jp>
-rw-r--r--package/kernel/linux/modules/netdevices.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index fb38079c43..4e4559f3fc 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -523,6 +523,23 @@ endef
$(eval $(call KernelPackage,igb))
+define KernelPackage/igbvf
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Intel(R) 82576 Virtual Function Ethernet support
+ DEPENDS:=@PCI_SUPPORT
+ KCONFIG:=CONFIG_IGBVF \
+ CONFIG_IGB_HWMON=n \
+ CONFIG_IGB_DCA=n
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/intel/igbvf/igbvf.ko
+ AUTOLOAD:=$(call AutoLoad,35,igbvf)
+endef
+
+define KernelPackage/igbvf/description
+ Kernel modules for Intel(R) 82576 Virtual Function Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,igbvf))
+
define KernelPackage/b44
TITLE:=Broadcom 44xx driver