aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:42 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:42 +0000
commit669584e5a5b9e8aa33d7552ee8686aac12406cd9 (patch)
tree9ce180b421287af7e77a50439a8c432caa7bfe6d
parent76fa8c1bf096d0f9ae5d9850476dd9d8bc87218f (diff)
downloadmaster-187ad058-669584e5a5b9e8aa33d7552ee8686aac12406cd9.tar.gz
master-187ad058-669584e5a5b9e8aa33d7552ee8686aac12406cd9.tar.bz2
master-187ad058-669584e5a5b9e8aa33d7552ee8686aac12406cd9.zip
[ramips] move rt305x-dwc driver to target specific modules.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32864 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/usb.mk21
-rw-r--r--target/linux/ramips/modules.mk26
2 files changed, 26 insertions, 21 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 87ae7077e0..02731dbd06 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -885,27 +885,6 @@ endef
$(eval $(call KernelPackage,usb-test))
-define KernelPackage/usb-rt305x-dwc_otg
- TITLE:=RT305X USB controller driver
- DEPENDS:=@TARGET_ramips_rt305x
- KCONFIG:= \
- CONFIG_DWC_OTG \
- CONFIG_DWC_OTG_HOST_ONLY=y \
- CONFIG_DWC_OTG_DEVICE_ONLY=n \
- CONFIG_DWC_OTG_DEBUG=n
- FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
- AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-rt305x-dwc_otg/description
- This driver provides USB Device Controller support for the
- Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
-endef
-
-$(eval $(call KernelPackage,usb-rt305x-dwc_otg))
-
-
define KernelPackage/usbip
TITLE := USB-over-IP kernel support
KCONFIG:= \
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
new file mode 100644
index 0000000000..0d293323f0
--- /dev/null
+++ b/target/linux/ramips/modules.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/usb-rt305x-dwc_otg
+ TITLE:=RT305X USB controller driver
+ DEPENDS:=@TARGET_ramips_rt305x
+ KCONFIG:= \
+ CONFIG_DWC_OTG \
+ CONFIG_DWC_OTG_HOST_ONLY=y \
+ CONFIG_DWC_OTG_DEVICE_ONLY=n \
+ CONFIG_DWC_OTG_DEBUG=n
+ FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+ AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-rt305x-dwc_otg/description
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-rt305x-dwc_otg))