aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-07-20 14:57:08 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-20 14:57:08 +0200
commit6567a9614b14663b1cbbb699e35eb8443d2fb5e2 (patch)
tree66a4791b1bd5c20967aea465d61819378e653b2c
parent677e743ac204090000fd26cddb38f9cc07b202bd (diff)
downloadmaster-187ad058-6567a9614b14663b1cbbb699e35eb8443d2fb5e2.tar.gz
master-187ad058-6567a9614b14663b1cbbb699e35eb8443d2fb5e2.tar.bz2
master-187ad058-6567a9614b14663b1cbbb699e35eb8443d2fb5e2.zip
prism54-firmware: change prism54/p54-firmware package versioning
There are multiple prism54/p54 firmware versions for different drivers and devices. Therefore, assigning the package version of all the different firmware packages on the old prism54 firmware could break if any of the p54 firmwares are updated and we need to roll out new packages. Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [removed PKG_VERSION] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/firmware/prism54-firmware/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/package/firmware/prism54-firmware/Makefile b/package/firmware/prism54-firmware/Makefile
index 32bd289520..780c29abde 100644
--- a/package/firmware/prism54-firmware/Makefile
+++ b/package/firmware/prism54-firmware/Makefile
@@ -6,24 +6,27 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=prism54-firmware
-PKG_VERSION:=1.0.4.3
PKG_RELEASE:=1
-PRG_URL:=https://daemonizer.de/prism54/prism54-fw/
-
# Prism54 FullMAC firmware (jbnore.free.fr seems to be rather slow, so we use daemonizer.de)
-PKG_SOURCE:=$(PKG_VERSION).arm
-PKG_SOURCE_URL:=$(PRG_URL)/fw-fullmac/
-PKG_MD5SUM:=8bd4310971772a486b9784c77f8a6df9
+PRG_URL:=https://daemonizer.de/prism54/prism54-fw/
include $(INCLUDE_DIR)/package.mk
-# Prism54 drivers
+# PRISM54/P54 firmwares
+PRISM54FW:=1.0.4.3.arm
P54USBFW:=2.13.24.0.lm87.arm
P54PCIFW:=2.13.12.0.arm
P54SPIFW:=2.13.0.0.a.13.14.arm
+define Download/prism54-firmware
+ FILE:=$(PRISM54FW)
+ URL:=$(PRG_URL)/fw-fullmac
+ MD5SUM:=8bd4310971772a486b9784c77f8a6df9
+endef
+$(eval $(call Download,prism54-firmware))
+
define Download/p54-usb-firmware
FILE:=$(P54USBFW)
URL:=$(PRG_URL)/fw-usb
@@ -83,7 +86,7 @@ endef
define Package/prism54-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware
- $(INSTALL_DATA) $(DL_DIR)/$(PKG_SOURCE) $(1)/lib/firmware/isl3890
+ $(INSTALL_DATA) $(DL_DIR)/$(PRISM54FW) $(1)/lib/firmware/isl3890
endef
define Package/p54-usb-firmware/install