aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-08-15 11:05:35 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-08-15 11:05:35 +0000
commit63a54df41ac57a53fb8db9c3d365dbba32fb9a3e (patch)
tree605fc1acf464429f4edd830864f6ec744eec0f1a
parent498d62ba6b32f6b7bd96501536919c98ede455bb (diff)
downloadmaster-187ad058-63a54df41ac57a53fb8db9c3d365dbba32fb9a3e.tar.gz
master-187ad058-63a54df41ac57a53fb8db9c3d365dbba32fb9a3e.tar.bz2
master-187ad058-63a54df41ac57a53fb8db9c3d365dbba32fb9a3e.zip
kernel: remove kmod-input-core just for some x86 profiles.
Not all x86 profiles have CONFIG_INPUT=y in their configuration. Just remove kmod-input-core for them. Thank you Philip Prindeville for pointing out this problem. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27988 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/001-depends.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index 602775c015..238799e2e5 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -27,11 +27,11 @@ endef
define SetDepends/input
- DEPENDS:= @!TARGET_x86
+ DEPENDS:= @!(TARGET_x86_generic||TARGET_x86_kvm_guest)
endef
define AddDepends/input
- DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
+ DEPENDS+= +!(TARGET_x86_generic||TARGET_x86_kvm_guest):kmod-input-core $(1)
endef