aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:01 +0000
commit62ba78a061f1c8b5c96d19c2f0bbe689b4707e13 (patch)
tree7fab52607872fa65fedbe8d62d7758ccf4b3e5c5
parentb33a6e836fb7bff1ecfa4416b7884ef88f738357 (diff)
downloadmaster-187ad058-62ba78a061f1c8b5c96d19c2f0bbe689b4707e13.tar.gz
master-187ad058-62ba78a061f1c8b5c96d19c2f0bbe689b4707e13.tar.bz2
master-187ad058-62ba78a061f1c8b5c96d19c2f0bbe689b4707e13.zip
ar71xx: image: use a single firmware partition on Compex devices
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39389 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 7531340206..5fe8ae4cbe 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -453,10 +453,16 @@ Image/Build/MyLoader/buildkernel=$(call PatchKernelLzma,$(2),$(3))
Image/Build/MyLoader/initramfs=$(call PatchKernel/initramfs,$(2),$(3))
define Image/Build/MyLoader
- -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) \
- -p0x030000:0xe0000:al:0x80060000:kernel:$(KDIR_TMP)/vmlinux-$(2).bin.lzma \
- -p0x110000:0:::rootfs:$(KDIR)/root.$(1) \
- $(call imgname,$(1),$(2))-$(5)-factory.img
+ $(eval fwsize=$(shell echo $$(($(4)-0x30000-4*64*1024))))
+ $(eval fwimage=$(KDIR_TMP)/$(2)-$(5)-firmware.bin)
+ $(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).bin.lzma,65536,$(KDIR)/root.$(1),$(fwsize),$(fwimage))
+ if [ -e "$(fwimage)" ]; then \
+ cp $(fwimage) $(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
+ $(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) -v \
+ -p0x00030000:0:al:0x80060000:firmware:$(fwimage) \
+ $(call imgname,$(1),$(2))-$(5)-factory.img; \
+ true; \
+ fi
endef