aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-22 14:37:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-22 14:37:07 +0000
commit62477818bb7022372aaa74634a51a8dddd7c7204 (patch)
treede042f817d85641e0d8a4be7fdb2db87e8516db8
parent0a6a5169d801824b824490463f3cbd4410fbc1c8 (diff)
downloadmaster-187ad058-62477818bb7022372aaa74634a51a8dddd7c7204.tar.gz
master-187ad058-62477818bb7022372aaa74634a51a8dddd7c7204.tar.bz2
master-187ad058-62477818bb7022372aaa74634a51a8dddd7c7204.zip
kernel: remove openwrt micrel.c (replaced by upstream driver)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43762 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/generic/files/drivers/net/phy/micrel.c83
-rw-r--r--target/linux/generic/patches-3.14/728-phy-micrel.patch24
-rw-r--r--target/linux/generic/patches-3.14/728-phy-rtl8367b.patch (renamed from target/linux/generic/patches-3.14/729-phy-rtl8367b.patch)4
-rw-r--r--target/linux/generic/patches-3.14/729-phy-tantos.patch6
-rw-r--r--target/linux/generic/patches-3.14/730-phy_b53.patch6
-rw-r--r--target/linux/generic/patches-3.18/728-phy-micrel.patch24
-rw-r--r--target/linux/generic/patches-3.18/728-phy-rtl8367b.patch (renamed from target/linux/generic/patches-3.18/729-phy-rtl8367b.patch)4
-rw-r--r--target/linux/generic/patches-3.18/729-phy-tantos.patch6
-rw-r--r--target/linux/generic/patches-3.18/730-phy_b53.patch6
9 files changed, 16 insertions, 147 deletions
diff --git a/target/linux/generic/files/drivers/net/phy/micrel.c b/target/linux/generic/files/drivers/net/phy/micrel.c
deleted file mode 100644
index 1499d4ace4..0000000000
--- a/target/linux/generic/files/drivers/net/phy/micrel.c
+++ /dev/null
@@ -1,83 +0,0 @@
-/*
- * Driver for Micrel/Kendin PHYs
- *
- * Copyright (c) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
- * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License version 2 as published
- * by the Free Software Foundation.
- *
- */
-
-#include <linux/module.h>
-#include <linux/delay.h>
-#include <linux/skbuff.h>
-#include <linux/phy.h>
-
-#define KSZ_REG_INT_CTRL 0x1b
-
-#define KSZ_INT_LU_EN (1 << 8) /* enable Link Up interrupt */
-#define KSZ_INT_RF_EN (1 << 9) /* enable Remote Fault interrupt */
-#define KSZ_INT_LD_EN (1 << 10) /* enable Link Down interrupt */
-
-#define KSZ_INT_INIT (KSZ_INT_LU_EN | KSZ_INT_LD_EN)
-
-static int ksz8041_ack_interrupt(struct phy_device *phydev)
-{
- int err;
-
- err = phy_read(phydev, KSZ_REG_INT_CTRL);
-
- return (err < 0) ? err : 0;
-}
-
-static int ksz8041_config_intr(struct phy_device *phydev)
-{
- int err;
-
- if (phydev->interrupts == PHY_INTERRUPT_ENABLED)
- err = phy_write(phydev, KSZ_REG_INT_CTRL,
- KSZ_INT_INIT);
- else
- err = phy_write(phydev, KSZ_REG_INT_CTRL, 0);
-
- return err;
-}
-
-static struct phy_driver ksz8041_phy_driver = {
- .phy_id = 0x00221512,
- .name = "Micrel KSZ8041",
- .phy_id_mask = 0x001fffff,
- .features = PHY_BASIC_FEATURES,
- .flags = PHY_HAS_INTERRUPT,
- .config_aneg = genphy_config_aneg,
- .read_status = genphy_read_status,
- .ack_interrupt = ksz8041_ack_interrupt,
- .config_intr = ksz8041_config_intr,
- .driver = {
- .owner = THIS_MODULE,
- },
-};
-
-static int __init micrel_phy_init(void)
-{
- return phy_driver_register(&ksz8041_phy_driver);
-}
-
-static void __exit micrel_phy_exit(void)
-{
- phy_driver_unregister(&ksz8041_phy_driver);
-}
-
-#ifdef MODULE
-module_init(micrel_phy_init);
-module_exit(micrel_phy_exit);
-#else
-subsys_initcall(micrel_phy_init);
-#endif
-
-MODULE_DESCRIPTION("Micrel/Kendin PHY driver");
-MODULE_AUTHOR("Gabor Juhos <juhosg@openwrt.org>");
-MODULE_AUTHOR("Imre Kaloz <kaloz@openwrt.org>");
-MODULE_LICENSE("GPL v2");
diff --git a/target/linux/generic/patches-3.14/728-phy-micrel.patch b/target/linux/generic/patches-3.14/728-phy-micrel.patch
deleted file mode 100644
index baf5a4a7fd..0000000000
--- a/target/linux/generic/patches-3.14/728-phy-micrel.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -144,6 +144,11 @@ config RTL8306_PHY
- tristate "Driver for Realtek RTL8306S switches"
- select SWCONFIG
-
-+config MICREL_PHY
-+ tristate "Drivers for Micrel/Kendin PHYs"
-+ ---help---
-+ Currently has a driver for the KSZ8041
-+
- config FIXED_PHY
- bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
- depends on PHYLIB=y
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
- obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
-+obj-$(CONFIG_MICREL_PHY) += micrel.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
- obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
diff --git a/target/linux/generic/patches-3.14/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
index d69fc89e47..36a82311fe 100644
--- a/target/linux/generic/patches-3.14/729-phy-rtl8367b.patch
+++ b/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -262,6 +262,10 @@ config RTL8367_PHY
+@@ -257,6 +257,10 @@ config RTL8367_PHY
tristate "Driver for the Realtek RTL8367R/M switches"
select SWCONFIG
@@ -19,5 +19,5 @@
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.14/729-phy-tantos.patch b/target/linux/generic/patches-3.14/729-phy-tantos.patch
index 4a9fe873a7..935193a58e 100644
--- a/target/linux/generic/patches-3.14/729-phy-tantos.patch
+++ b/target/linux/generic/patches-3.14/729-phy-tantos.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -273,3 +273,8 @@ endif # PHYLIB
+@@ -268,3 +268,8 @@ endif # PHYLIB
config MICREL_KS8995MA
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
depends on SPI
@@ -11,10 +11,10 @@
+ select ETHERNET_PACKET_MANGLE
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+@@ -29,6 +29,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.14/730-phy_b53.patch b/target/linux/generic/patches-3.14/730-phy_b53.patch
index cd58182f7e..27b8197e15 100644
--- a/target/linux/generic/patches-3.14/730-phy_b53.patch
+++ b/target/linux/generic/patches-3.14/730-phy_b53.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -268,6 +268,8 @@ config RTL8367B_PHY
+@@ -263,6 +263,8 @@ config RTL8367B_PHY
endif # RTL8366_SMI
@@ -11,9 +11,9 @@
config MICREL_KS8995MA
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+obj-$(CONFIG_B53) += b53/
obj-$(CONFIG_FIXED_PHY) += fixed.o
diff --git a/target/linux/generic/patches-3.18/728-phy-micrel.patch b/target/linux/generic/patches-3.18/728-phy-micrel.patch
deleted file mode 100644
index 95199a4348..0000000000
--- a/target/linux/generic/patches-3.18/728-phy-micrel.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -156,6 +156,11 @@ config RTL8306_PHY
- tristate "Driver for Realtek RTL8306S switches"
- select SWCONFIG
-
-+config MICREL_PHY
-+ tristate "Drivers for Micrel/Kendin PHYs"
-+ ---help---
-+ Currently has a driver for the KSZ8041
-+
- config FIXED_PHY
- bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
- depends on PHYLIB=y
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -29,6 +29,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
- obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
-+obj-$(CONFIG_MICREL_PHY) += micrel.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
- obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
diff --git a/target/linux/generic/patches-3.18/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.18/728-phy-rtl8367b.patch
index cc4f7940d2..958ff58907 100644
--- a/target/linux/generic/patches-3.18/729-phy-rtl8367b.patch
+++ b/target/linux/generic/patches-3.18/728-phy-rtl8367b.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -281,6 +281,10 @@ config RTL8367_PHY
+@@ -276,6 +276,10 @@ config RTL8367_PHY
tristate "Driver for the Realtek RTL8367R/M switches"
select SWCONFIG
@@ -19,5 +19,5 @@
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.18/729-phy-tantos.patch b/target/linux/generic/patches-3.18/729-phy-tantos.patch
index 6262ef9803..019f919492 100644
--- a/target/linux/generic/patches-3.18/729-phy-tantos.patch
+++ b/target/linux/generic/patches-3.18/729-phy-tantos.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -292,3 +292,8 @@ endif # PHYLIB
+@@ -287,3 +287,8 @@ endif # PHYLIB
config MICREL_KS8995MA
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
depends on SPI
@@ -11,10 +11,10 @@
+ select ETHERNET_PACKET_MANGLE
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.18/730-phy_b53.patch b/target/linux/generic/patches-3.18/730-phy_b53.patch
index 5e13797630..c2dfcfa501 100644
--- a/target/linux/generic/patches-3.18/730-phy_b53.patch
+++ b/target/linux/generic/patches-3.18/730-phy_b53.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -287,6 +287,8 @@ config RTL8367B_PHY
+@@ -282,6 +282,8 @@ config RTL8367B_PHY
endif # RTL8366_SMI
@@ -11,9 +11,9 @@
config MICREL_KS8995MA
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -32,6 +32,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+obj-$(CONFIG_B53) += b53/
obj-$(CONFIG_FIXED_PHY) += fixed.o