aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-10 19:07:26 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-10 19:07:26 +0000
commit622ef1800223dd4155d8dea9a5449c67d4bb5ed2 (patch)
tree0917501900d2ec771076ff4acab20a1c32927d07
parenta988d3db4ad7dbff842dbd9d24cb555e06b4d681 (diff)
downloadmaster-187ad058-622ef1800223dd4155d8dea9a5449c67d4bb5ed2.tar.gz
master-187ad058-622ef1800223dd4155d8dea9a5449c67d4bb5ed2.tar.bz2
master-187ad058-622ef1800223dd4155d8dea9a5449c67d4bb5ed2.zip
ar71xx: add support for the Telldus TellStick ZNet Lite
Signed-off-by: Micke Prag <micke.prag@telldus.se> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48977 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds5
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh6
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.11
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tellstick-znet-lite.c129
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/generic/profiles/telldus.mk17
-rw-r--r--target/linux/ar71xx/image/Makefile9
13 files changed, 189 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 6cec5dfbdd..eff6e0d451 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -407,6 +407,11 @@ smart-300)
ucidef_set_led_wlan "wlan" "WLAN" "nc-link:green:wlan" "phy0tpt"
;;
+tellstick-znet-lite)
+ ucidef_set_led_netdev "lan_act" "LANACT" "tellstick:green:lan" "eth0" "tx rx"
+ ucidef_set_led_netdev "lan_link" "LANLINK" "tellstick:orange:lan" "eth0" "link"
+ ;;
+
tew-712br)
ucidef_set_led_netdev "wan" "WAN" "trendnet:green:wan" "eth1"
ucidef_set_led_switch "lan1" "LAN1" "trendnet:green:lan1" "switch0" "0x02"
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index 799d98e881..e88ef3a5ed 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -192,6 +192,11 @@ el-m150)
"0:lan" "1:lan" "3@eth1" # XXX: confirm!
;;
+tellstick-znet-lite)
+ ucidef_set_interface_wan "eth0" "dhcp"
+ ucidef_set_interface_raw "wlan" "wlan0" "dhcp"
+ ;;
+
tl-wdr4300|\
tl-wr1041n-v2)
ucidef_add_switch "switch0" \
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index db69757d9f..d083a799fa 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -263,6 +263,9 @@ get_status_led() {
qihoo-c301)
status_led="qihoo:green:status"
;;
+ tellstick-znet-lite)
+ status_led="tellstick:white:system"
+ ;;
tew-632brp)
status_led="tew-632brp:green:status"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 804f622983..46f1685647 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -120,6 +120,9 @@ tplink_board_detect() {
"120000"*)
model="MERCURY MAC1200R"
;;
+ "007260"*)
+ model="TellStick ZNet Lite"
+ ;;
"3C0001"*)
model="OOLITE"
;;
@@ -749,6 +752,9 @@ ar71xx_board_detect() {
"Smart Electronics Black Swift board"*)
name="bsb"
;;
+ *"Telldus TellStick ZNet Lite")
+ name="tellstick-znet-lite"
+ ;;
*TEW-632BRP)
name="tew-632brp"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 8a70502323..d41081942a 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -336,6 +336,7 @@ platform_check_image() {
onion-omega | \
oolite | \
smart-300 | \
+ tellstick-znet-lite | \
tl-mr10u | \
tl-mr11u | \
tl-mr12u | \
diff --git a/target/linux/ar71xx/config-4.1 b/target/linux/ar71xx/config-4.1
index 0ccb2787dd..0570749f8e 100644
--- a/target/linux/ar71xx/config-4.1
+++ b/target/linux/ar71xx/config-4.1
@@ -123,6 +123,7 @@ CONFIG_ATH79_MACH_R6100=y
# CONFIG_ATH79_MACH_RBSXTLITE is not set
CONFIG_ATH79_MACH_RW2458N=y
CONFIG_ATH79_MACH_SMART_300=y
+CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE=y
CONFIG_ATH79_MACH_TEW_632BRP=y
CONFIG_ATH79_MACH_TEW_673GRU=y
CONFIG_ATH79_MACH_TEW_712BR=y
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index bef1863c67..c9ee1228d6 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -126,6 +126,7 @@ CONFIG_ATH79_MACH_R6100=y
# CONFIG_ATH79_MACH_RBSXTLITE is not set
CONFIG_ATH79_MACH_RW2458N=y
CONFIG_ATH79_MACH_SMART_300=y
+CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE=y
CONFIG_ATH79_MACH_TEW_632BRP=y
CONFIG_ATH79_MACH_TEW_673GRU=y
CONFIG_ATH79_MACH_TEW_712BR=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 3d6dc4dfc3..8256b0e238 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -754,6 +754,16 @@ config ATH79_MACH_SMART_300
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_TELLSTICK_ZNET_LITE
+ bool "TellStick ZNet Lite"
+ select SOC_AR933X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_WNDAP360
bool "NETGEAR WNDAP360 board support"
select SOC_AR71XX
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index c1bbee16d1..0f8410a45f 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -130,6 +130,7 @@ obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
obj-$(CONFIG_ATH79_MACH_SMART_300) += mach-smart-300.o
+obj-$(CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE) += mach-tellstick-znet-lite.o
obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
obj-$(CONFIG_ATH79_MACH_TEW_712BR) += mach-tew-712br.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tellstick-znet-lite.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tellstick-znet-lite.c
new file mode 100644
index 0000000000..0950d9a99d
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tellstick-znet-lite.c
@@ -0,0 +1,129 @@
+/*
+ * Telldus TellStick ZNet Lite board support
+ *
+ * Copyright (C) 2016 Micke Prag <micke.prag@telldus.se>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TELLSTICK_GPIO_LED_SYSTEM 27
+#define TELLSTICK_GPIO_LED_BLUE 0
+#define TELLSTICK_GPIO_LED_RED 14
+#define TELLSTICK_GPIO_LED_GREEN 15
+#define TELLSTICK_GPIO_LED_LAN_GREEN 16
+#define TELLSTICK_GPIO_LED_LAN_ORANGE 17
+
+#define TELLSTICK_GPIO_BTN_RESET 11
+
+#define TELLSTICK_GPIO_RF433_RESET 13
+
+#define TELLSTICK_KEYS_POLL_INTERVAL 20 /* msecs */
+#define TELLSTICK_KEYS_DEBOUNCE_INTERVAL (3 * TELLSTICK_KEYS_POLL_INTERVAL)
+
+static const char *tellstick_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data tellstick_flash_data = {
+ .part_probes = tellstick_part_probes,
+};
+
+static struct gpio_led tellstick_leds_gpio[] __initdata = {
+ {
+ .name = "tellstick:white:system",
+ .gpio = TELLSTICK_GPIO_LED_SYSTEM,
+ .active_low = 0,
+ },
+ {
+ .name = "tellstick:blue:status",
+ .gpio = TELLSTICK_GPIO_LED_BLUE,
+ .active_low = 0,
+ },
+ {
+ .name = "tellstick:red:status",
+ .gpio = TELLSTICK_GPIO_LED_RED,
+ .active_low = 0,
+ },
+ {
+ .name = "tellstick:green:status",
+ .gpio = TELLSTICK_GPIO_LED_GREEN,
+ .active_low = 0,
+ },
+ {
+ .name = "tellstick:green:lan",
+ .gpio = TELLSTICK_GPIO_LED_LAN_GREEN,
+ .active_low = 0,
+ },
+ {
+ .name = "tellstick:orange:lan",
+ .gpio = TELLSTICK_GPIO_LED_LAN_ORANGE,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button tellstick_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = TELLSTICK_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TELLSTICK_GPIO_BTN_RESET,
+ .active_low = 0,
+ }
+};
+
+static void __init tellstick_znet_lite_setup(void)
+{
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+ u8 mac[ETH_ALEN];
+ memcpy(&mac, (u8 *) KSEG1ADDR(0x1f01fc00), sizeof(mac));
+
+ ath79_gpio_function_disable(
+ AR933X_GPIO_FUNC_ETH_SWITCH_LED0_EN |
+ AR933X_GPIO_FUNC_ETH_SWITCH_LED1_EN |
+ AR933X_GPIO_FUNC_ETH_SWITCH_LED2_EN |
+ AR933X_GPIO_FUNC_ETH_SWITCH_LED3_EN |
+ AR933X_GPIO_FUNC_ETH_SWITCH_LED4_EN
+ );
+
+ ath79_register_m25p80(&tellstick_flash_data);
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(tellstick_leds_gpio),
+ tellstick_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, TELLSTICK_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(tellstick_gpio_keys),
+ tellstick_gpio_keys);
+
+ gpio_request_one(TELLSTICK_GPIO_RF433_RESET,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "rf433 reset");
+ ath79_register_usb();
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, (u8 *)mac, 0);
+
+ ath79_register_mdio(0, 0x0);
+ ath79_register_eth(0);
+
+ // wlan0 mac needs to be different then eth0
+ mac[3] += 1;
+ ath79_register_wmac(ee, (u8 *)mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_TELLSTICK_ZNET_LITE, "TELLSTICK-ZNET-LITE", "Telldus TellStick ZNet Lite",
+ tellstick_znet_lite_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 97de9f035c..e965f440c2 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -144,6 +144,7 @@ enum ath79_mach_type {
ATH79_MACH_RB_SXTLITE5ND, /* Mikrotik RouterBOARD SXT Lite 5nD */
ATH79_MACH_RW2458N, /* Redwave RW2458N */
ATH79_MACH_SMART_300, /* NC-LINK SMART-300 */
+ ATH79_MACH_TELLSTICK_ZNET_LITE, /* TellStick ZNet Lite */
ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
ATH79_MACH_TEW_712BR, /* TRENDnet TEW-712BR */
diff --git a/target/linux/ar71xx/generic/profiles/telldus.mk b/target/linux/ar71xx/generic/profiles/telldus.mk
new file mode 100644
index 0000000000..d0dffe08cf
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/telldus.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TELLSTICKZNETLITE
+ NAME:=TellStick ZNet Lite
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-acm kmod-usb-serial kmod-usb-serial-pl2303
+endef
+
+
+define Profile/TELLSTICKZNETLITE/Description
+ Package set optimized for the TellStick ZNet Lite.
+endef
+$(eval $(call Profile,TELLSTICKZNETLITE))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ca4437b4b8..44b9178906 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1061,6 +1061,15 @@ define Device/smart-300
endef
TARGET_DEVICES += smart-300
+define Device/tellstick-znet-lite
+ $(Device/tplink-16mlzma)
+ BOARDNAME := TELLSTICK-ZNET-LITE
+ DEVICE_PROFILE := TELLSTICKZNETLITE
+ TPLINK_HWID := 0x00726001
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += tellstick-znet-lite
+
define Device/oolite
$(Device/tplink-16mlzma)
BOARDNAME := GS-OOLITE