aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-18 11:18:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-18 11:18:37 +0000
commit61b763d414aee61d16bc29f29670f1ac2f425422 (patch)
treea9172b8c080f2205a21a7857cfc091806f63d392
parentde904cbdf823eee0b9e05a511e59adbf3a1da47c (diff)
downloadmaster-187ad058-61b763d414aee61d16bc29f29670f1ac2f425422.tar.gz
master-187ad058-61b763d414aee61d16bc29f29670f1ac2f425422.tar.bz2
master-187ad058-61b763d414aee61d16bc29f29670f1ac2f425422.zip
build: add required exports for dependency tracking
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37387 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/package-ipkg.mk5
-rw-r--r--rules.mk2
2 files changed, 5 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 73fed05b17..696de156cf 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -54,7 +54,10 @@ ifneq ($(PKG_NAME),toolchain)
@( \
rm -f $(PKG_INFO_DIR)/$(1).missing; \
( \
- export READELF=$(TARGET_CROSS)readelf XARGS="$(XARGS)"; \
+ export \
+ READELF=$(TARGET_CROSS)readelf \
+ OBJCOPY=$(TARGET_CROSS)objcopy \
+ XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
grep -q "$$$$FILE" $(PKG_INFO_DIR)/$(1).provides || \
diff --git a/rules.mk b/rules.mk
index 2e9e20d919..5ed8000e05 100644
--- a/rules.mk
+++ b/rules.mk
@@ -14,7 +14,7 @@ endif
include $(TOPDIR)/include/debug.mk
include $(TOPDIR)/include/verbose.mk
-TMP_DIR:=$(TOPDIR)/tmp
+export TMP_DIR:=$(TOPDIR)/tmp
GREP_OPTIONS=
export GREP_OPTIONS